Forums

Delete MySQL Database

Hello,

maybe I'm doing something entirely wrong, but I don't seem to be able to delete/drop a previously created MySQL Database. When I try, the shell tells me that I have insufficient rights. Any suggestions?

Regards, Philipp

It works for me. In the MySQL console:

mysql> use catweazle$test;
Database changed
mysql> drop database catweazle$test;
Query OK, 0 rows affected (0.00 sec)
mysql> use catweazle$test;
ERROR 1049 (42000): Unknown database 'catweazle$test'
mysql>

@philippmuller, does the code that catweazle suggested work for you?

Do web applications use the same MySQL user as the web-based MySQL console?

Thank you all, the code that catweazle suggested worked after I closed all my Consoles and opened a new one right out the the MySQL Tab..

Not really sure why I didn't have permission before, but it all worked out now:)

@Cartroo, your webapps should use the same MySQL user otherwise they won't have permission to access your database.

@glenn: Thanks. I figured that was likely the case, but I thought it was conceivable that two users might be created which are both given the same access. Single user does make life simpler!