Forums

OpenSSL -V 1.1.1

hello

what should i do to solve this problem?

because my code dose not work at all.

DEPRECATION: The OpenSSL being used by this python install (OpenSSL 1.0.2g 1 Mar 2016) does not meet the minimum supported version (>= OpenSSL 1.1.1) in order to support TLS 1.3 required by Cloudflare, You may encounter an unexpected Captcha or cloudflare 1020 blocks.

What are you trying to do when you get that message?

I try connected to https server and put the same problem. Need (>=openssl 1.1.1)

We have openssl 1.1.1f installed, so I don't think you're getting that error on PythonAnywhere.

edit: It appears that I was wrong when I posted this, 1.0.2g is the latest version of OpenSSL the is available on PythonAnywhere.

Hi there, I'm experiencing the same issue. When I run "openssl version" in pythonanywhere bash, I get "OpenSSL 1.0.2g 1 Mar 2016".

I'm also getting "OpenSSL 1.0.2g 1 Mar 2016", and I was wondering how I can access this "openssl 1.1.1f " mentioned above?

When I type "openssl version" I get: "OpenSSL 1.0.2g 1 Mar 2016"

And "hostname" gives: "blue-liveconsole1"

I read on the openssl.org website that:

"Note: The latest stable version is the 1.1.1 series. This is also our Long Term Support (LTS) version, supported until 11th September 2023. All older versions (including 1.1.0, 1.0.2, 1.0.0 and 0.9.8) are now out of support and should not be used. Users of these older versions are encourage to upgrade to 1.1.1 as soon as possible. Extended support for 1.0.2 to gain access to security fixes for that version is available." --from: OpenSSL website: https://www.openssl.org/source/

The "1.0.2g" version does have some vulnerabilities: https://www.cvedetails.com/vulnerability-list/vendor_id-217/product_id-383/version_id-194420/Openssl-Openssl-1.0.2g.html

Both @sbridgett and @cyaris, you have older system images. We can update your system image, but note that switching to the new version may break some of your existing code that worked on older versions. You may need to recreate any virtualenvs that you're using and you will need to start new consoles and reload your web apps. You will also need to kill any ipython notebook processes that are running by using the "Fetch processes" button on the Consoles page.

Let us know if you'd like to update your system image.

Hi! Seems like I use the latest system image (fishnchips), but I get "OpenSSL 1.0.2g 1 Mar 2016" when I run "openssl version" command.

I'm sorry. I was wrong in the post where I said that 1.1.1f was available in the latest system image. 1.0.2g is the latest that is available on PythonAnywhere.

I noticed that there is a newer "glastonbury" system image ( https://www.pythonanywhere.com/batteries_included/ ) and one of the packages in this system image is "pyOpenSSL" version "20.0.1":

 3.9    pyOpenSSL    20.0.1     Python wrapper module around the OpenSSL library

The pyOpenSSL version 20.0.1 has dropped support for openSSL versions 1.0.1 and 1.0.2 ( https://pypi.org/project/pyOpenSSL/ ).

And the glastonbury image is based on Ubuntu 20.04 ( https://help.pythonanywhere.com/pages/ChangingSystemImage ) which I think has openSSL 1.1.1 ?

So I assume this glastonbury system image is using openSSL version 1.1.0 or 1.1.1 ?

It's 1.1.1 on glastonbury. You can change your system image from the "Account" page. There's more information on this help page: https://help.pythonanywhere.com/pages/ChangingSystemImage.

Thank you. I'll change to the glastonbury system image now.