Forums

django.core.exceptions.ImproperlyConfigured: SQLite 3.8.3 or later is required (found 3.8.2).

I am getting this error, and unable to start my app. How do I update my SQLite to v3.8.3.

Thanks!

Your account needs to be upgraded to the new system image. One word of warning first -- because changing the system image upgrades a lot of the pre-installed Python packages, any code that you have that relies on those packages might break if it's not compatible with the new versions. Also, because the new image has newer versions of Python, if you have any virtualenvs, you may need to rebuild them. If you're happy to go ahead despite that, just let us know and we'll switch you over.

I am getting the same error listed here. Does my account need to be switched as well?

Probably.

okay cool are you able to do that for me?

No problem. I have switched your account to the new image.

thanks!

Hey. I'd love to get switched as well :)

That's done. No problem.

Hello, I'm having the same problem. Would you please help me to fix it?

Ok. I have updated your system image.