There was an error saving.

I can't saving changes. Checked my perms via ls -l. Look fine. Was working OK yesterday.

I got this error today too (around 10AM eastern time), I'm guessing it's something on the PA servers.

I'm still getting it. Not getting anything done right now :(

my work around was to code on the website, copy / paste it to a document on my computer (Notepad), and upload it to my folder on this site.

Your browsers are caching old resources. Use shift-reload on the pages to fix it.

Dude I cleared c&c hours ago and relogged. the heck. It's working now after doing it again.

Is there a solution to this problem? I currently get this when trying to edit any existing document.

My work around is to open a Bash, then use "nano" to edit it and save in the nano editor, bypassing the online web edit feature

Hm, I can see a few hits to a file called /home/shawnrkimble/test which are returning 403 -- could you have created a read-only file accidentally somehow? Or could you be using a browser whose login has expired (if you have the editor open in one tab, but you've logged out in another tab, for example)?

Turning off my adblocker seemed to help. It was working fine and then stopped halfway through a project.

We need more details to help you. What stopped halfway through?

Turning off adblocker worked for me

Glad to hear that!

Been using the PA editor for a few months now and today for the first time I am consistently getting the "There was an error saving." error. I am not able to edit code in the editor. I am not getting this error 100% of the time I am trying to save a file only about 90%. What information do you need to help me fix this issue?

We were hit by a DDoS attack yesterday, so the site was running very slowly at around the time you posted. Has the problem cleared up now? We had a mitigation in place about 20 minutes after you posted your message.

Yes, now it works again! Thanks for the response and for clearing it up so quickly!

Also getting a "There was an error saving" when trying to save anything, in any browser.

Can we, please, be able to work?


Same here.

Reports that Pythonanywhere is down.

Apologies for the service disruption today. It was due to a significant DDOS attack on our servers. This one took us a bit longer than I would have likely to deal with. Apologies for any inconvenience caused.