My console is wierdly small.. (picture inside)

This is how my console looks like inside my Chrome window.. I've tried disable all of my exstensions but with no luck..

The console is big in Firefox, but it gets stuck on connect in that browser, so I cant use that.

Any ideas how to fix this?

Here's a picture

SOLVED: worked after I uninstalled chrome

That's weird... It might have been the browser using old, cached, css? Shift + Refresh can fix that sometimes. You shouldn't have to uninstall chrome!

I can add another case of this happening. I killed all my consoles and now all my attempts to make new consoles come up in Chrome looking like the example picture.

Shift+Referesh didn't seem to help. Nor did closing Chrome completely and restarting.

Tried adding /frame/ to end to make full screen, but that didn't alter either.

Tried closing Chrome and completely shutting down and restarting computer (Windows-based) and still had the issue. While consoles generated in FireFox look normal.

I even uninstalled within Window's Control panel and reinstalled Chrome and it is still doing it.

I cleared the browsing data from the beginning of time with all options on and closed. When I repopen and login to PAW, it still just opens the one line thick black window like in the picture the frst poster, Felix, posted.

SOLVED: Felix's solution did work, but I had to uninstall from 'uninstall' shortcut in Window's Start menu. By doing it that way, I got an option that didn't come up when I uninstalled in Windows list of installed programs in Control Panel. I selected 'yes' to the option to destroy all old browsing data and then reinstallation after that restored my PythonAnywhere windows to be normal in Chrome. What a pain to fix.


That is weird. One thing that might help fix down the cause is (if you or anyone else sees this bug again) - what happens if you start an "incognito" window? (Ctrl+Shift+N) that should start with a fresh profile, so it might be another good way of clearing down caches...

I have the same problem (console in chrome as in the picture). It works on Firefox and Safari for me.

I tried CTRL + SHIFT + N, but that did not work either.

What solved this for me was setting the zoom to the standard size. CTRL+- (ctrl-minus) did the trick for me; setting it back to a smaller zoom setting and refreshing the page resulted in a totally normal, big console! I'm guessing the fixes mentioned above worked because the browser finally no longer remembered the enhanced zoom no

[POSSIBLE FIX] Cf decisioncandy's answer, you can try this:

  • Hit Ctrl+0 (control-zero) to reset chrome's zoom level for the page
  • Hit refresh (F5)

I had the same problem as described by the first post, here.

Apparently, the action that caused the error was my using Chrome's CONTROL+PLUS to zoom into the screen. First, that screwed up PythonAnywhere's screen text output. At that point I could not zoom out (CONTROL+MINUS) or reset (CONTROL+ZERO). The zoom feature appeared to be disabled. Prior to that, F5 and SHIFT+F5 seemed to have no effect. Finally, I encountered the error described here (one horizontal black line with the prompt), after reloading into a new page.

This process solved the problem for me:

1.) Log out of your PythonAnywhere session. 2.) Open a new page and navigate to the PythonAnywhere login page. 3.) Reset Chrome zoom level to standard (CONTROL+ZERO). 4.) Log into PythonAnywhere. 5.) Open a new session.

Steps 1 and 2 may not be needed; but, at the very least, I believe you have to load or re-open a session into a page that has not been zoomed away from Chrome's standard page size.

Thanks, Brian -- I think that the ^0 and ^+ keypresses must be being grabbed by the terminal. I've confirmed that I can reproduce the problem by zooming before I go to the console screen -- zooming in while I'm on the console page doesn't seem to cause the problem. You can fix it as you described, by going back to the dashboard and then hitting ^0, but it also looks like it can be fixed by clicking on the console page outside the console itself -- for example, on the console name near the top left -- and then, once the font size has gone back to the default, hitting the "Refresh" button.

Now that we have a repro it should be much easier to fix, so many thanks, everyone!

Thanks to everyone for posting a useful solutions. That is much easier than uninstalling and reinstalling. Fortunately, I haven't been victimized by it happening again recently.

Making text the default size worked for my Webkit browsers, but I was getting a two line console with no prompt in Firefox 12.0. I eventually found I needed to disable the AdBlock Plus V2.03 Firefox extension.

@davidsands - thanks for that... I wonder if FF13 will fix things?

I'm using FF 14.0a2 (2012-05-29) (wow I need to update it's been a week) and have no problems with many extensions operating with PythonAnywhere. Although AdBlock Plus is one I don't use.

I suppose the point in me posting is to say let me know if you'd like me to try something out.

Hi a2j, do you mean that you can get this problem to occur in FF 14? Our main problem was reproducing it. I've only seen it once myself... It took us absolutely ages to realise that it was the Zoom feature in Chrome that did it. For that browser anyway.

@hansel: Sorry for not being more clear in my post. I have NEVER had this issue. I was just pointing out that I'm using a future version of FF since FF was mentioned above. And also that I roll with an unusually large amount of extensions. I have never had this trouble. If I can do anything to help test I'd be glad to contribute my experiences.

Ah ha! Well that's all good then. Thanks for the offer, but yes our main problem really is reproducing it in any way. The hardest part is basically telling you what to try :-)

Good err I mean BAD news...I just got a 9 row high console window.

  • FF version 15.0a2 (2012-06-15)
  • Windows 7 Home Premium SP 1
  • Toshiba Satellite A505
  • Intel Core i7 Q720
  • 8GB RAM
  • 64-bit OS

I tried changing the size of the zoom and verified that I started out at normal. Oddly enough I just duplicated my exact steps to see if I could repeat the results and my next console was normal. Sorry I'm not actually helping with this post, but I guess you knowing it still does exist is ultimately helpful to you. Okay, here is what I did.

  1. I went to my <Files> tab.
  2. I changed to a sub directory.
  3. I typed in a new file name and clicked <New>.
  4. I pasted in 675 lines of code from this page.
  5. Clicked on <Save & Run>.

When I repeated the exact steps above it worked fine the second time.

Right, sounds like in that instance a bit of Javascript wasn't loaded. I've seen that a occur a couple of times. Usually associated with a timeout on some resource or other. Not a huge problem but something we could minimise by minimising, and aggregrating code perhaps.

I just noticed something this morning when I opened a console. As the console was drawn it started out at that 8 line high size and then grew to normal size. Based on hansel's last post I'm guessing you already knew this happens (just normally so fast you don't see it), so I'm probably not accomplishing anything by this post, but hoping to aide you by confirming that as the window draws I can (sometimes) see the pause of the terminal window at the size it (sometimes) gets stuck at. Obviously this all points to the problem being a client side issue (which you already knew) and you also already likely know where the code is getting 'caught.'

Small console resolved on ChromeBox.

This problem occurred on my ChromeBox today. I had the one-line sized console in Python, Bash, and IPython. I could issue commands, and they were executing normally, but scrolling by one line at a time.

Uninstalling Chrome is not an option for me.

Thanks to thwe previous posters here and the new search function on the forums:

I pressed CTRL - 0 (zero) to reset the zoom option, pressed CTRL - r to refresh the page, and everything worked again.

I didn't have to log out and log back in.

Thanks, -Steve

Thanks, ssanty! That certainly should do the trick, so it's good to hear that it does.

+1 ssanty

Thanks for letting us know -- I've upvoted putting the time in to fix this on our to-do list. It's likely to be pretty tricky, though, so I can't promise a fix soon.