Forums

Error, do this: mount -t proc proc /proc

I am getting this error both on pushes from local to remote and when starting a bash console on PA.

I have been away from PA for a while, but I don't think I've seen this error before.

steve@LT5:~/psr2$ GIT_SSH_COMMAND="ssh -vvv" git push sc-test OpenSSH_6.9p1 Ubuntu-2ubuntu0.2, OpenSSL 1.0.2d 9 Jul 2015 debug1: Reading configuration data /etc/ssh/ssh_config debug1: /etc/ssh/ssh_config line 19: Applying options for debug2: ssh_connect: needpriv 0 debug1: Connecting to ssh.pythonanywhere.com [23.21.200.247] port 22. debug1: Connection established. debug1: identity file /home/steve/.ssh/id_rsa type 1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_rsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_dsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_dsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_ecdsa type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_ecdsa-cert type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_ed25519 type -1 debug1: key_load_public: No such file or directory debug1: identity file /home/steve/.ssh/id_ed25519-cert type -1 debug1: Enabling compatibility mode for protocol 2.0 debug1: Local version string SSH-2.0-OpenSSH_6.9p1 Ubuntu-2ubuntu0.2 debug1: Remote protocol version 2.0, remote software version OpenSSH_6.6.1p1 Ubuntu-2ubuntu2.7 debug1: match: OpenSSH_6.6.1p1 Ubuntu-2ubuntu2.7 pat OpenSSH_6.6.1 compat 0x04000000 debug2: fd 3 setting O_NONBLOCK debug1: Authenticating to ssh.pythonanywhere.com:22 as 'stevetone' debug3: hostkeys_foreach: reading file "/home/steve/.ssh/known_hosts" debug3: record_hostkey: found key type RSA in file /home/steve/.ssh/known_hosts:13 debug3: load_hostkeys: loaded 1 keys from ssh.pythonanywhere.com debug3: order_hostkeyalgs: prefer hostkeyalgs: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa debug1: SSH2_MSG_KEXINIT sent debug1: SSH2_MSG_KEXINIT received debug2: kex_parse_kexinit: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1 debug2: kex_parse_kexinit: ssh-rsa-cert-v01@openssh.com,ssh-rsa-cert-v00@openssh.com,ssh-rsa,ecdsa-sha2-nistp256-cert-v01@openssh.com,ecdsa-sha2-nistp384-cert-v01@openssh.com,ecdsa-sha2-nistp521-cert-v01@openssh.com,ssh-ed25519-cert-v01@openssh.com,ssh-dss-cert-v01@openssh.com,ssh-dss-cert-v00@openssh.com,ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,ssh-ed25519,ssh-dss debug2: kex_parse_kexinit: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se debug2: kex_parse_kexinit: chacha20-poly1305@openssh.com,aes128-ctr,aes192-ctr,aes256-ctr,aes128-gcm@openssh.com,aes256-gcm@openssh.com,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se debug2: kex_parse_kexinit: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1,hmac-md5-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96 debug2: kex_parse_kexinit: umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-sha1,hmac-md5-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96 debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib debug2: kex_parse_kexinit: debug2: kex_parse_kexinit: debug2: kex_parse_kexinit: first_kex_follows 0 debug2: kex_parse_kexinit: reserved 0 debug2: kex_parse_kexinit: curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1 debug2: kex_parse_kexinit: ssh-rsa,ssh-dss debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-gcm@openssh.com,aes256-gcm@openssh.com,chacha20-poly1305@openssh.com,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96 debug2: kex_parse_kexinit: hmac-md5-etm@openssh.com,hmac-sha1-etm@openssh.com,umac-64-etm@openssh.com,umac-128-etm@openssh.com,hmac-sha2-256-etm@openssh.com,hmac-sha2-512-etm@openssh.com,hmac-ripemd160-etm@openssh.com,hmac-sha1-96-etm@openssh.com,hmac-md5-96-etm@openssh.com,hmac-md5,hmac-sha1,umac-64@openssh.com,umac-128@openssh.com,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96 debug2: kex_parse_kexinit: none,zlib@openssh.com debug2: kex_parse_kexinit: none,zlib@openssh.com debug2: kex_parse_kexinit: debug2: kex_parse_kexinit: debug2: kex_parse_kexinit: first_kex_follows 0 debug2: kex_parse_kexinit: reserved 0 debug1: kex: server->client chacha20-poly1305@openssh.com <implicit> none debug1: kex: client->server chacha20-poly1305@openssh.com <implicit> none debug1: expecting SSH2_MSG_KEX_ECDH_REPLY debug1: Server host key: ssh-rsa SHA256:zy2jmqxNg/fs6tFZK55OjHTI3B2UofzOiUvTPtcX3/Y debug3: hostkeys_foreach: reading file "/home/steve/.ssh/known_hosts" debug3: record_hostkey: found key type RSA in file /home/steve/.ssh/known_hosts:13 debug3: load_hostkeys: loaded 1 keys from ssh.pythonanywhere.com debug3: hostkeys_foreach: reading file "/home/steve/.ssh/known_hosts" debug3: record_hostkey: found key type RSA in file /home/steve/.ssh/known_hosts:14 debug3: load_hostkeys: loaded 1 keys from 23.21.200.247 debug1: Host 'ssh.pythonanywhere.com' is known and matches the RSA host key. debug1: Found key in /home/steve/.ssh/known_hosts:13 debug2: set_newkeys: mode 1 debug1: SSH2_MSG_NEWKEYS sent debug1: expecting SSH2_MSG_NEWKEYS debug2: set_newkeys: mode 0 debug1: SSH2_MSG_NEWKEYS received debug1: SSH2_MSG_SERVICE_REQUEST sent debug2: service_accept: ssh-userauth debug1: SSH2_MSG_SERVICE_ACCEPT received debug2: key: /home/steve/.ssh/id_rsa (0x56277b1ae970), debug2: key: /home/steve/.ssh/id_dsa ((nil)), debug2: key: /home/steve/.ssh/id_ecdsa ((nil)), debug2: key: /home/steve/.ssh/id_ed25519 ((nil)), debug3: input_userauth_banner <<<<<<:>~ PythonAnywhere SSH. Help @ https://www.pythonanywhere.com/wiki/SSHAccess debug1: Authentications that can continue: publickey,password debug3: start over, passed a different list publickey,password debug3: preferred gssapi-keyex,gssapi-with-mic,publickey,keyboard-interactive,password debug3: authmethod_lookup publickey debug3: remaining preferred: keyboard-interactive,password debug3: authmethod_is_enabled publickey debug1: Next authentication method: publickey debug1: Offering RSA public key: /home/steve/.ssh/id_rsa debug3: send_pubkey_test debug2: we sent a publickey packet, wait for reply debug1: Server accepts key: pkalg ssh-rsa blen 279 debug2: input_userauth_pk_ok: fp SHA256:pTgcl6ORvUxW9fCX5yx5hXPSHPgDQB6FRSyBSfM+G7A debug3: sign_and_send_pubkey: RSA SHA256:pTgcl6ORvUxW9fCX5yx5hXPSHPgDQB6FRSyBSfM+G7A debug1: Authentication succeeded (publickey). Authenticated to ssh.pythonanywhere.com ([23.21.200.247]:22). debug2: fd 5 setting O_NONBLOCK debug2: fd 6 setting O_NONBLOCK debug1: channel 0: new [client-session] debug3: ssh_session2_open: channel_new: 0 debug2: channel 0: send open debug1: Requesting no-more-sessions@openssh.com debug1: Entering interactive session. debug2: callback start debug2: fd 3 setting TCP_NODELAY debug3: ssh_packet_set_tos: set IP_TOS 0x08 debug2: client_session2_setup: id 0 debug1: Sending environment. debug3: Ignored env LESSOPEN debug3: Ignored env VIRTUALENVWRAPPER_WORKON_CD debug3: Ignored env GNOME_KEYRING_PID debug3: Ignored env GIT_SSH_COMMAND debug3: Ignored env USER debug3: Ignored env WORKON_HOME debug3: Ignored env LANGUAGE debug3: Ignored env UPSTART_INSTANCE debug3: Ignored env XDG_SEAT debug3: Ignored env SESSION debug3: Ignored env XDG_SESSION_TYPE debug3: Ignored env COMPIZ_CONFIG_PROFILE debug3: Ignored env SHLVL debug3: Ignored env OLDPWD debug3: Ignored env HOME debug3: Ignored env QT4_IM_MODULE debug3: Ignored env DESKTOP_SESSION debug3: Ignored env GTK_MODULES debug3: Ignored env XDG_SEAT_PATH debug3: Ignored env INSTANCE debug3: Ignored env GIT_PREFIX debug3: Ignored env DBUS_SESSION_BUS_ADDRESS debug3: Ignored env GNOME_KEYRING_CONTROL debug3: Ignored env QT_QPA_PLATFORMTHEME debug3: Ignored env MANDATORY_PATH debug3: Ignored env IM_CONFIG_PHASE debug3: Ignored env SESSIONTYPE debug3: Ignored env UPSTART_JOB debug3: Ignored env LOGNAME debug3: Ignored env GTK_IM_MODULE debug3: Ignored env WINDOWID debug3: Ignored env _ debug3: Ignored env DEFAULTS_PATH debug3: Ignored env XDG_SESSION_ID debug3: Ignored env TERM debug3: Ignored env GNOME_DESKTOP_SESSION_ID debug3: Ignored env GTK2_MODULES debug3: Ignored env PATH debug3: Ignored env GDM_LANG debug3: Ignored env XDG_SESSION_PATH debug3: Ignored env XDG_RUNTIME_DIR debug3: Ignored env PROJECT_HOME debug3: Ignored env COMPIZ_BIN_PATH debug3: Ignored env DISPLAY debug1: Sending env LANG = en_US.UTF-8 debug2: channel 0: request env confirm 0 debug3: Ignored env XDG_CURRENT_DESKTOP debug3: Ignored env LS_COLORS debug3: Ignored env XMODIFIERS debug3: Ignored env XDG_SESSION_DESKTOP debug3: Ignored env XAUTHORITY debug3: Ignored env XDG_GREETER_DATA_DIR debug3: Ignored env SSH_AUTH_SOCK debug3: Ignored env SHELL debug3: Ignored env GDMSESSION debug3: Ignored env VIRTUALENVWRAPPER_PROJECT_FILENAME debug3: Ignored env LESSCLOSE debug3: Ignored env VIRTUALENVWRAPPER_HOOK_DIR debug3: Ignored env UPSTART_EVENTS debug3: Ignored env GPG_AGENT_INFO debug3: Ignored env UPSTART_SESSION debug3: Ignored env XDG_VTNR debug3: Ignored env VIRTUALENVWRAPPER_SCRIPT debug3: Ignored env QT_IM_MODULE debug3: Ignored env PWD debug3: Ignored env CLUTTER_IM_MODULE debug3: Ignored env XDG_CONFIG_DIRS debug3: Ignored env XDG_DATA_DIRS debug3: Ignored env VTE_VERSION debug3: Ignored env JOB debug1: Sending command: git-receive-pack '/home/stevetone/git-repositories/sc-test.git' debug2: channel 0: request exec confirm 1 debug2: callback done debug2: channel 0: open confirm rwindow 0 rmax 32768 debug2: channel 0: rcvd adjust 2097152 debug2: channel_input_status_confirm: type 99 id 0 debug2: exec request accepted on channel 0 debug2: channel 0: rcvd ext data 41 Error, do this: mount -t proc proc /proc debug2: channel 0: written 41 to efd 7 fatal: protocol error: bad line length character: Init debug2: channel 0: read<=0 rfd 5 len 0 debug2: channel 0: read failed debug2: channel 0: close_read debug2: channel 0: input open -> drain debug2: channel 0: ibuf empty debug2: channel 0: send eof debug2: channel 0: input drain -> closed debug2: channel 0: write failed debug2: channel 0: close_write debug2: channel 0: send eow debug2: channel 0: output open -> closed debug2: channel 0: rcvd ext data 74 debug1: client_input_channel_req: channel 0 rtype exit-status reply 0 debug2: channel 0: rcvd ext data 43 debug2: channel 0: rcvd eof debug2: channel 0: rcvd close debug3: channel 0: will not send data after close debug2: channel 0: almost dead debug2: channel 0: gc: notify user debug2: channel 0: gc: user detached debug2: channel 0: send close debug2: channel 0: is dead debug2: channel 0: garbage collecting debug1: channel 0: free: client-session, nchannels 1 debug3: channel 0: status: The following connections are open: #0 client-session (t4 r0 i3/0 o3/0 fd -1/-1 cc -1)
debug1: fd 0 clearing O_NONBLOCK debug1: fd 1 clearing O_NONBLOCK Transferred: sent 3440, received 3356 bytes, in 10.3 seconds Bytes per second: sent 333.6, received 325.4 debug1: Exit status 128

What happens if you try to just ssh in without the git push?

The ssh works fine, but I get that same "proc" error msg. Here are the last few lines of verbose output for the ssh command ssh -v stevetone@ssh.pythonanywhere.com:

Authenticated to ssh.pythonanywhere.com ([23.21.200.247]:22).
debug1: channel 0: new [client-session]
debug1: Requesting no-more-sessions@openssh.com
debug1: Entering interactive session.
debug1: Sending environment.
debug1: Sending env LANG = en_US.UTF-8
Error, do this: mount -t proc proc /proc
Initializing new SSH agent...
succeeded
Identity added: /home/stevetone/.ssh/id_rsa (/home/stevetone/.ssh/id_rsa)

That sounds like maybe your bashrc or something is doing something that requires proc. Did you recently add something to your bashrc? (since that will get run upon ssh-ing in)

Traditionally, you could never access /proc

I do not think I have ever edited the default .bashrc file. At least not recently. Here it is:

# Load up standard site-wide settings.
source /etc/bashrc
source virtualenvwrapper.sh
SSH_ENV=$HOME/.ssh/environment
# start the ssh-agent
function start_agent {
    echo "Initializing new SSH agent..."
    # spawn ssh-agent
    /usr/bin/ssh-agent | sed 's/^echo/#echo/' > "${SSH_ENV}"
    echo succeeded
    chmod 600 "${SSH_ENV}"
    . "${SSH_ENV}" > /dev/null
    /usr/bin/ssh-add
}
if [ -f "${SSH_ENV}" ]; then
     . "${SSH_ENV}" > /dev/null
     ps -ef | grep ${SSH_AGENT_PID} | grep ssh-agent$ > /dev/null || {
        start_agent;
    }
else
    start_agent;

There is a "ps" command in that .bashrc. That appears to be generating the error message.

Is there a default .bashrc that I should have?

I setup a free new account and copied the .bashrc from there. Problem solved :)

I'm seeing this error when I run pipenv install in my bash console here on Pythonanywhere.

Yes, it looks like pipenv doesn't work with our virtualization system right now :-(

FWIW, I see that error, but apart from that, it seems to play nicely with my virtualenv, and actually installs what I ask it to.

Interesting! Maybe the sandboxing system is only causing problems with a non-essential feature of pipenv. We'd love to know how you get on with it.

I am seeing this, just running ps -ef. I moved .bashrc over to bashrc.org, logged in again, and still see this error. I wonder if something has changed

No, nothing has changed. ps will still not work and if your bashrc is not running it, then something must be. Examine the error that you see to see if you can work out what is running the command that is causing the error.