PythonAnywhere Forums

Android Status?

If I open a PythonAnywhere console on my Nexus 7 tablet, I can type exactly one character. I surprised that I can't find much information about PythonAnywhere on Android. I would think that it is a FAQ. Is it supposed to work? If not, will it work someday? Can anyone fill me in? Thanks!

I've occasionally used PythonAnywhere on an Android Tablet (Asus Transformer) without problems and without deviating from the way I'd use it on a PC. I used the Firefox browser..

@corrt one character? that's a new one to us. our Android support is patchy, but as catweazle says, it should work OK. Which browser are you using? Can you try a different one? Can you describe the problem in more detail?

I am using a "Samsung Galaxy Note 10"+"Android ICS" , here are a few issues:

  • the console does'nt play well with the on screen keyboard. I've been trying both firefox and safary. The text that is entered into the keyboard isn't properly forwarded to the console. Safary: Some characters are randomly uppercased. If you type "print", you get "prInt" ! Firefox: The predicted text is added to the entry. If you type "print", you get "pprpriprinprint" => Workaround : switching off the predictive text in the keyboard setup solved this issue.

  • The Web tab is partially emtpy in Firefox ( but OK in safary ) , there is no link to the running website and no reload button.

Yikes, I've been considering getting an Android based tablet.

@corrt, @derivationBud: Welcmoe to PA. Stick with it through the issues, these guys are awesome and they'll get them fixed if you keep letting them know.

@derivationBud, I would think that Chrome is much more likely to be useable.

@glenn, Thanks for the tip : Chrome gives good results so far ( very limited testing ) . I do'nt see this usable enough to be a dev platfrom but it certainly helps to build tablet-friendly sites . Thanks

I also use chrome on android. I upgraded to the most recent chrome version. I have the same issue that I can only type one character - the rest is ignored.

@xsteve: Welcome to PA. It's a pleasure to have you join us here on the forum!!!

@xsteve -- thanks for letting us know. Which device and Android version are you using? We're trying to work out which ones we should buy and test for first.

@giles: You have my address. Be sure to send me whatever unit you want me testing for you...☺

Edit: I'll stay up all night drinking out of my favorite mug performing the requisite testing!

I have the same issue just types one charecter, from google chrome..also tried "request desktop page" still same problem.

Thanks for letting us know.

Is there an update on this issue? I tried both Firefox and Chrome, also "request desktop" but still running buggy. Thanks a lot for your great job!

hi there, what is the particular bugginess that you are seeing?

For example deleting with backspace deletes not just the last character but also parts of the bash console for instance.

Yeah. I see similar behaviour. I don't think there's much we can do about it in the short term, though.

OK, I understand. If I notice an "alternative solution" I will update this topic. Good job guys, thx!