My Django app returns '502 Bad Gateway'

I updated my Django app, pulling my latest commits from BitBucket, and reinstalled my dependencies (including Django 1.5.1). I think it even worked for a while, before I tried to change my static file paths, but now I'm getting a 502 Bad Gateway error, no matter what I do. Care to shed some light on this?

I get the same issue when trying to use sqlite3

502 Bad Gateway


The same when returning to MySQL. Also, no lines added to the error log.

Getting the same with a basic flask app.

I'm also seeing this issue.

i am also seeing the same issue with my app and no log lines are added to access logs and error logs

I echo aquasan.

:normal ggvGyy<CR>P

Last acces entry: [27/Mar/2013:06:19:03 +0000] Last error entry (depreciation warning): 2013-03-26 22:08:15,200

using django 1.4.5 with a couple of plugins in a virtualenv and sqlite3.

It must be something on the pythonanywhere servers. All of the applications returning same error. There is nothing to do except waiting which is boring.

We're investigating, apologies for the outage. It's outside office hours here, and our automated systems should have alerted us to the error but it looks like this isn't triggering them.

More news as we find out what the problem is.

Looks like one of our web servers got overloaded, which took out web apps that were hosted there. We've switched everything over to a backup, and I've double-checked that all web apps belonging to people who've posted on this thread are running.

Apologies for the outage, we'll look into the underlying cause and why we didn't get an automated alert tomorrow.

thanks giles, really appreciate it.

12:54am? I should hope that's out of office hours... (^_^)

Heh, it's worse than that - the timestamps here are UTC so it was 1:54 when I wrote...

Ouch! Still, it's excellent practice if you ever have children... (^_^)

Thank you very much!

No problem! Sorry again for the outage.