web2py "unable to check for upgrades"

Running web2py "Version 2.3.2 (2012-12-17 15:03:30) stable"

Receive "unable to check for upgrades" when selecting button.

Anybody else having this problem?

That's strange. I just tried it in a free account and it worked perfectly (upgraded to 2.4.4 from 2.3.2). Are there any errors in your logs?

Could it be an instance of this issue? That's an upgrade from 2.3.2 to 2.4.2, and it seems to be something about the version format having changed. Or later on there's some discussion that the button might be just plain broken. I'm afraid I rather lost the will to read beyond a certain point due to the awful (and inexcusable) proliferation of top-posted responses with no trimming. I really wish mailing list software summarily rejected any message with more than 2-3 levels of quoting...

Anyway, doesn't explain why Glenn didn't have a problem, however, assuming that was an upgrade from the same version.

It works now - I think it was a problem with going from 2.3.2 to 2.4.2 as you indicated but going to 2.4.4 worked (by the way, the new version looks great ...)

Excellent, I'm glad to hear it's working! Thanks @Cartroo for finding the problem out :-)

By the power of Google... I HAVE THE POWER!

(Until I lose 3G reception)

I trust you're holding your phone above your head heroically as you say that?

Actually I just get really good mobile reception with this sword. Well, as long as I don't wield it in my left hand. Plus the display is really sharp.

So, who would you say is your Skeletor?

Hm, that's a tricky one, and also sounds oddly like something that might crop up in a celebrity interview in Heat magazine.

Perhaps some sort of Hydra with the heads of Larry Wall, Rasmus_Lerdorf and whoever designed SNMP.

And all the people who think XML is a great framework for a high-level networking protocol.

And anybody who indents Python with tabs.

And... It's a good job the Hydra has so many heads, eh?

Indeed. But I think Dante did have a special circle for those tab-using monsters.

Vroooooooooooooooommmmmm....that is the sound of this topic whizzing over my head...☺

Not the original topic btw.

This doesn't ring any bells?

By the power of Greyskull!! Never really watched it, but thanks for the episode of this retro-moment©...☺