Forums

Consoles stuck on "Starting encrypted connection to on port 443"

If I open a new console it works fine, but I can't view any of my running consoles. How do I fix this?

Sorry about that, it's a bug in our configuration. A fix is being prepared and will be live shortly.

That should be fixed now. You'll need to hit refresh on any stuck consoles...

Thanks for lettings us know! Do shout out again if you see any more problems.

Having this problem at the moment starting the MySQL console. Any ideas?

That is strange; there are no errors being logged on the system, and I was able to start MySQL, bash and Python consoles -- but looking back at our logs I can see connections coming in for your MySQL console but nothing after that -- it's as if the specific MySQL process you're connecting to is dead.

Have you tried killing that MySQL console and starting a fresh one? And are you able to start Python and Bash ones?

I figured it out. I had deleted my default database. I have been working with another database for my webapp instead of the default. Once I created a new default database it's working fine.

Ah, right -- that makes sense. I'll log a bug against this anyway -- we should have a better error message in this case -- or perhaps prompt you for the database to connect to.

BTW, I'm not sure if it's obvious, but if you want to start a MySQL console on a non-default database, you can click on the DB name on the MySQL tab.

Thank you for the info.

I can't wait to have this problem when I delete my default PG database...☺

But on a serious note...Any update on PG?

Nothing yet... the problem is mostly infrastructural; we get quite a lot of good stuff -- backups, etc -- for free from Amazon AWS by using their RDS service for MySQL... and so we need to build a lot of it ourselves for PostgreSQL. Might take a little while :-(

hi there,

Consoles stuck on "Starting encrypted connection to on port 443" please fix the problem. thanks

hi there,

this account has the same problem.

please fix it.

thanks

and me

Hi there -- sorry about that, one of our console servers is having some problems. I've taken it out of service while we fix it.

Just so clarify things: when you start a console, it's randomly allocated to one of the console servers. So if you see this problem, normally you can work around it by starting a new console.

hi there,

this account has the same problem.

please fix it.

thanks

Having the same problem with some of my consoles. However, scheduled task are running correctly.

Thanks.

Hi there, one of the servers (consoles-8) did have a glitch, we've kicked it over -- are things working again?

we should normally get automated alerts for this, but that server wasn't in the list for some reason. we've added it now...

hi there,

this account has the same problem.

please fix it.

thanks

Yes, same to me.

Hi there, could you try closing any consoles (from the Consoles tab) that are currently having problems connecting and then re-open them?

I have close them. But the consoles dont run again.

Three of my consoles stucked from last night

My colleagues just deployed a new fix -- will you give it another try?

Same problem now...

I'm currently experiencing this issue

Sorry about that, we had some more console server problems earlier on -- they should have been fixed a few moments after you posted your message.

Seems to be working now. Thanks!

Seems to be working now. Thanks!

I am having this same problem. I've killed all my consoles, but whenever I try to run a new program, it gets stuck again. Thanks!

Im experiencing the same issue again

Hi,

I am seeing the same message" Starting encrypted connection to consoles-2.pythonanywhere.com on port 443" since today morning.

It was working fine till yesterday night. I did not make any changes to my code since yesterday night.

Please look into it.

Thanks, Naveen.

Good day Python Staff,

This error is interesting as it seems like the problem is recurrent, stemming from a problem 5 years ago.

Please look into further detail what the culprit of this issue and so that it does not happen in the future.

Thanks,

Juan

I completely agree with Juan.

Its also very frustrating that non of my scripts have been running for over 6 hours now with no response or acknowledgement of this issue from the staff.

hi there,

Consoles stuck on "Starting encrypted connection to on port 443". please fix the problem. thanks

Its also very frustrating that non of my scripts have been running for over 6 hours now with no response or acknowledgement of this issue from the staff.

Honestly it's insane that we didn't even get an email about this.

Again the same error:

Starting encrypted connection to consoles-2.pythonanywhere.com on port 443

And no solutions..

It must be Sunday and they are enjoying the premier league football. waste my time

hi everyone, thanks for reporting this. one of our console servers (console 2) seems like it was under heavy load- we have taken steps to rectify this- do let us know if you are still seeing any problems. For future reference, if you see this issue again, do please report it, but if you kill any of your existing console-2 consoles and start new ones, they will start randomly on different consoles that are unaffected.

Sorry again for all the inconveniences!

Looks like its fixed now. Thanks !!

hi there,

Consoles stuck on "Loading Python3.5 interpreter...". please fix the problem. thanks

We're not aware of any console server problems at the moment. Could you give us the ID of the console that's showing the problem? It's the number in the URL.

[edit: removed reference to system update, as the previous post was made at 7:57pm, not am)

hi, all of them have the same problem. but at the time anything is normal.

OK, thanks -- it sounds like whatever was causing this was fixed by the system update this morning. We replaced all of the console servers with new machines, so presumably that did it. We'll keep an eye out, and please do let us know if it happens again.