SSH Issues from a Particular Machine

I feel bad because this likely isn't any issue with PythonAnywhere, but I can't for the life of me establish an SSH connection from my home computer. It is a 64-bit machine running Windows 10. Using PuTTY, I receive a 'Network error: Connection timed out' error, and similar errors when trying to access it from other applications such as HeidiSQL and Cygwin64.

The very first time I tried PuTTY from this computer, I was successful. From my work computer I'm able to reliably connect via PuTTY as well as TOAD for MySQL, so I'm pretty sure I'm using the applications correctly at least.

I've tried using the IP address instead of I've tried it with the Windows Firewall and my anti-virus disabled. I've tried it in Safe Mode with Networking. I even tried resetting my modem because I ran out of ideas that actually made sense to try.

Is there any chance that PythonAnywhere is refusing my connection on that end? Has anyone else run into similar issues or has some other things that should be on my checklist?

EDIT: I was given a login prompt when connecting to (also on port 22) via PuTTY, so i'm not prohibited from connecting to SSH hosts or using that port for outgoing connections entirely. Just PythonAnywhere from what I can tell.

EDIT2: Unsuccessful connecting on the same network from another machine, although I haven't tried this machine successfully on another network, so unsure how much that tells me. Went through my router firewall settings and dropped them all as low as possible and still no luck. I'm thinking either PythonAnywhere refusing my connection or Comcast being Comcast. Assuming the latter...

One possibility that comes to mind is that you might have been blocked if you made a number of repeated login attempts. But it's unlikely that that's the cause, because (a) we only block you if you make something like ten failed attempts in a 5 minute period, and (b) we only block you for ten minutes, and it sounds like you've been trying to debug this for a while!

An alternative -- maybe there really was something wrong with SSH on PythonAnywhere last night. We just deployed a new version of the site, and part of that involved replacing the SSH server with a new machine. So perhaps if you try again now it will work?

It's working this morning! Thank you!!!