MySql console not returning results - seems stuck


I'm using the mysql console to test out new queries but since yesterday i'm having issues. Yesterday, most of the day, pythonanywhere was experiencing some down time I think, but today I am not receiving responses from my mysql console.

'show tables;' worked, but simple select statements don't return anything. The cursor is just showing as if it's still running.

----------------copy paste from my console----------

mysql> show tables;
| Tables_in_viktorkn$pricetrackerscrape |
| pricetrackerscrape                    |
| trackingemaildb                       |
2 rows in set (0.01 sec)

mysql> select * from pricetrackerscrape limit 1;
(cursor stuck on this line)

UPDATE: my published webapp is also down. I have been trying to optimise my SQL query and this worked fine. However, now the page gets stuck when I execute the query. I have reverted my changes to the previous version, which has been working fine for months, but the issue remains. Are you experiencing any issues on your end?

this is the error log:

2024-02-12 18:05:42 get received
2024-02-12 18:10:44 Mon Feb 12 18:10:43 2024 - *** HARAKIRI ON WORKER 1 (pid: 10, try: 1) ***
2024-02-12 18:10:44 Mon Feb 12 18:10:43 2024 - HARAKIRI !!! worker 1 status !!!
2024-02-12 18:10:44 Mon Feb 12 18:10:43 2024 - HARAKIRI [core 0] - GET /search_api?origin=London&destination=Brussels&date=2024-02-29 since 1707761142
2024-02-12 18:10:44 Mon Feb 12 18:10:43 2024 - HARAKIRI !!! end of worker 1 status !!!
2024-02-12 18:10:44 DAMN ! worker 1 (pid: 10) died, killed by signal 9 :( trying respawn ...
2024-02-12 18:10:44 Respawned uWSGI worker 1 (new pid: 18)
2024-02-12 18:10:44 spawned 2 offload threads for uWSGI worker 1

We aren't having any MySQL server issues right now. Perhaps there is a long query running against your tables that is blocking others? If you start a fresh MySQL console and run show processlist; then that will show you what you have running.

oh wow, I wasn't aware that there might be a queue and that it stayed even if you deleted the console. I had a bunch of queries stuck in there. Thanks for you very quick reply, was able to unblock it by using 'KILL'+id. My webapp runs normal again as well.

Glad to hear that you made it work!