Error installing carbon

Hi. I tried pip installing carbon and I got this message:

error: can't combine user with with prefix/exec_prefix/home or install_(plat)base
    Complete output from command /usr/local/bin/python2.7 -c "import setuptools;__file__='/tmp/pip-        build/carbon/';exec(compile(open(__file__).read().replace(
'\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-Zz9WxG-record/install-record.txt --single-version-externally-managed --user:
    running install

error: can't combine user with with prefix/exec_prefix/home or install_(plat)base

It seems to be telling me I don't have permissions to do that. Is it possible for you guys to help me install it, as I want to play around with graphite.


Brief note: you need to prefix preformat lines with 4 spaces, which is why the text hasn't quite formatted correctly. Every line in the block requires the same 4-space indent.

I wonder if it's for the same reason as this SO question? On the chance that it's the same thing, might be worth trying the workaround suggested there (i.e. creating the .pydistutils.cfg file in your home directory to override the default prefix).

Thank you for helping me figure out how to format my python code posts.

In the mean time, I did try the suggestion given in the SO post, but I always get the response: "is a directory".

I tend tried to pip install carbon directly (again), and this time I get the response "could not create /opt: permission denied". I am assuming that this is because my program is trying to write directly into the root directory. Is there a way round this, or am do I just forget about graphite? I am using a borrowed windows system, otherwise I would have just created a linux partition (at the very least) so I could play with it (graphite). Thank you.

Are you using the --user option? As in:

pip install --user carbon

That should install it in your home directory rather than globally (of course, normal users don't have permission to do it globally).

Hmm, I've just tried it with the .pydistutils.cfg and the --user flag, and see the same error. Investigating...

On looking into carbon a bit more, it appears to be a Twisted daemon that listens for time-series data, in particular from the Graphite system monitoring tool. So while the installation problem is weird, it looks like it might not work on PythonAnywhere anyway -- we only support web applications that use WSGI, not apps that listen on specific ports.

But perhaps there are parts of it that might be usable -- could you explain a bit more what you're planning to do with it?

I did add the --user flag and it still didn't work. I was just trying to learn it, as it is a problematic install for windows.

Ah, OK. Unfortunately it doesn't look like we can help much here with that :-(