CKEditor not working properly after install

CKEditor not working properly after install.

The textarea is plain without RichTextEditor tools.

We followed all the steps including collectstatic, and we did migration, and its still not working.

We followed the guide on here and other solutions offered here and none seemed to work.

We suspect our issue is unique and we hope you can help us identify it and resolve it.

Here is our





   from ckeditor.fields import RichTextField

   description = RichTextField(null=True)

Please note that in our Web App configs, we set the URL to /static/.

Are we doing something wrong?

We never had this issue.

It looks like an issue with static files though -- do you see any errors like Not found: /some/path/to/static/file in the bottom of your web app's error log? If so, check this help page.

No errors at all.

Just the textfield area not showing the RichTextEditor.

It works perfectly locally.

Please advise.

Thank you

Are you seeing any errors in the browser's developer console when you try to access a page that should be showing the ckeditor?

In our development env. it works.

There are no errors.

The RichTextEditor is simply not there.

Get you get into our account and check?

We did everything precisely according to the guides on this forum.

Thank you

In your browser dev tools you would be able to see if there are any files that it's not able to get. that may tell you what's wrong with your static files.



please help us resolve this one issue we can't make anything out of this--please provide more support, don't rush with us. not everyone is a professional, please assist us properly, be more specific with your instructions dont talk in riddles, this is not good customer service, we will not hire a pro just because of this,

We got everything to work locally, and we installed everything properly, all the statics were collected, why s this not working?

Open the browser and go to your site, then open developers tools (e.g. in Chrome it's Ctrl-Shift-I, you should be able to find it in the menu under Tools or something similar). When it's open, switch to the Network tab (in the dev-tools window) and reload the page. You will see all requests listed, check if there are any errors (like 404) in the requests related with ckeeditor.

We want this to work in the admin area. We don't want it to work in the template. And there are no errors when we tried your solution

Is there some way that we can see this in action? For example, would you be able to provide us with a URL where the problem occurs, and any relevant login credentials? You could send the credentials to, as of course it would be a bad idea to post them on these forums where they would be visible to other people.

i emailed you, please check.

plesae note that we want the RichTextEditor to work in the admin area.

thank you

We got it. We will take a look.

thank you

Nada todavia? Yo tambien necesito ayuda :C

Encontre el siguiente error: El recurso de “” fue bloqueado debido a una discordancia del tipo MIME (“text/html”) (X-Content-Type-Options: nosniff)

Could provide errors that you get in English?

for anyone that's having this issue lately:

STATIC_URL = '/static/'

#STATICFILES_DIRS = [BASE_DIR / "static"] # comment is needed for development only

STATIC_ROOT = os.path.join(BASE_DIR, 'static')

then in bash console

python collectstatic