Forums

Why can't I use any console today?

I tried to open python and bash consoles, the console seems to load (Connecting to ec2-107-20-6-81.compute-1.amazonaws.com on port 8001 displays then fades out), but the cursor keep blinking without displaying any prompt.

I never had this problem before.

I tried in 3 browsers (2 webkit based, one gecko based), one without any extensions and vanilla settings, all up to date. Using Ubuntu 11.10 64 bits.

I'm currently in Africa, Mali, so the connection is not very good. I suppose it can have an influence but this works:

http://tryruby.org/levels/1/challenges/1

And youtube videos works too, so the connection can't be that bad.

I can edit text files without any problems.

Ok, today it works...

Hi Ksamuel,

Sorry about that. Our servers had a lot of heavy usage yesterday which may have been causing the problem. Also you may have noticed that we've been making a lot of infrastructure changes to help scale the service and there may be some bugs we need to iron out.

Also: Wow! Mali? That's cool.

Cheers

Hansel

Hello there,

I seem to have the same issue. I was thinking that maybe it had to do with the fact that I am behind a proxy in my company.

I'll try tomorrow, but I hope it'll work soon, because obviously, it would be a great solution for me to be able to write django apps from my browser, instead of my bad working station.

See you soon

Sorry about that. We have been having some issues with scaling. It should be working now and we have some changes in the pipeline that should stop it from happening again.

Is this still an issue for other users? I just created an account and I don't have a prompt for any consoles.

I have the same problem today. The console shows up as being open but I get no prompt. The cursor blinks in the top left hand corner of the screen.

Cob

Is it possible to ssh in? I just tried to do that to pythonanywhere.com port 22 but couldn't get a connection.

Cob

I just looked through the forums and it looks like this console situation is a recurring problem. This is very disappointing. Definitely a showstopper for me. Oh well I'll look elsewhere.

Cmon guys you have repeated complaints about the same problem. Fix it already.

Hi Cob,

Yup, it is/was a recurring problem which (thank god) we've actually just finished writing a fix for. We are deploying it today so there will be a little maintenance downtime in an hour or so. It took a while to get it sorted because it was one of those hard problems. Euch!

Cheers

Thanks for finally fixing, Hansel! In the future, can you post some kind of notification when issues/downtime are in effect or planned? I had a very frustrating and embarrassing time trying to enthusiastically introduce Django to several fellow students yesterday using pythonanywhere, for example, and could have just gone without pa if I had known consoles were down.

Thanks again!

Absolutely, and I'm sorry your Django demo was borked. We still have downtime when we deploy new version of PythonAnywhere (though we got the last one down to 8 minutes and we plan on eliminating it entirely) so if you are ever using us for a presentation do drop us a line and let us know. That way we will make sure to not change anything when you're doing it.

Since I posted my complaint yesterday that problem has (apparently) been fixed. Time will tell... Now I have another connection problem and that is when I type into my console sometimes what I type is repated many times. So, for example, if I type "123" at the command line I get "123123123123". This is a royal pain in the neck. What is the problem now guys?

And now it's worse. The line I type goes on many, many lines. Try doing some intelligent work with this crap. This is ridiculous. Anybody else experiencing this or just me?

Hmmm, that's strange. We're not seeing that problem on live or during any of our integration tests. What browser and OS are you using? The only time I've seen anything like what you are describing I was using the Swype keyboard on my android phone and it was going a bit haywire.

Definitely not a problem for everyone. The only issue I am aware of that sounds similar is a problem in Chrome that occurs when you have the same console open in multiple tabs. Text can appear to arrive out of order but is fixed if you do a page refresh. So yeah, some more details about your setup would be a big help in debugging this problem.

  1. Operating System
  2. Browser
  3. What shell you are running
  4. What applications you are running inside the shell

Feel free to send them through the feedback link if you are worried about privacy.

I'm using the same exact set up as I have since I got my account there and I never had the problem I'm having now until last night. I've tried closing the pythonanywhere browser I'm using and opening a new one and also logging off and on all to no avail. I'm having this problem when I have one browser window open and when I type anything in the bash shell at the command line or using the vi editor. I'm using Firefox (Explorer won't open a browser window) with Windows 7. That's it. And, as I said, it never happened before last night and now its pretty constant.

Another day another problem. I waited 10 minutes for a console to open. Then I type 4 letters and guess what? The console freezes! What a surprise!!! So I'll wait another 10 minutes for another console. And then I'll type 4 letters and the console will fill with those 4 letters x 100 times like it did yesterday. Or maybe it will just freeze.

Maybe I shouldn't have complained to begin with. Oh wait if I hadn't the console problem wouldn't have been fixed anyway.

This sounds very strange, it's definitely working for me right now (I've checked Firefox and Chrome on Win7 and also Android Honeycomb) so perhaps changes we introduced recently have broken things for a specific configuration which our automated tests don't catch. Do you have any FF addons installed? Some people have reported problems using PythonAnywhere with AdBlock plus, and while the effects they saw were very different, there could be a connection.

One other possibility is that somehow Firefox cached some of our old code before the update the other day, and is now using a mixture of the old and new. We've got stuff in there to stop that from happening, but there might be a failure case we've not anticipated. So it would help us debug it you could clear your browser cache and then try again.

Ok I'll do that and keep you posted.

Useless. More gibberish. Cmon guys this is pathetic. I guess the lesson learned DO NOT COMPLAIN ABOUT PYTHONANYWHERE ON THE PYTHONANYWHERE FORUM!

We're actually very keen on getting reports of problems people have with PythonAnywhere. It uses quite a lot of bleeding-edge software to get the browser-based console to work, and unfortunately that means that there can be odd interactions between it and different operating systems, browsers, plugins, and the like, as well as occasional hard-to-debug crashes on our server side. We want it to work for everyone, everywhere, but the only way we can get it to do that is if people tell us when something goes wrong with their specific configuration. So, many thanks for reporting the problem you're seeing.

I take it from your last message that clearing the cache didn't work. Do you have any browser add-ons at all installed?

No I don't. Well, I'm being patient because I was really impressed with the pa concept and your work on getting this thing up and running. All I can say is I'll see how it goes in the future.

I was on earlier today and had two consoles open which I didn't close when I closed the browser window. I just tried to access both of the PA consoles and all I got was a blinking cursor at the top left corner of the screen. Waited for 10 minutes with no progress.... I also tried opening a new console and only got the blinking cursor. This is the same problem as was reported by users the other day. Per the previous posts on this thread this problem was supposedly fixed the other day.

can't enter any char in consoles now

Eight hours later and I still just get a blinking cursor and no active console. Anybody there?

Sorry for the outage -- one of our servers had stopped responding, so I've restarted it and everything seems to be working OK again. It's a new issue -- the effect you saw (blinking cursor and nothing else in the console) means that the in-browser console can't connect to the server, which can be a symptom of many different problems, either server- or client-side. Additionally, for me this new problem meant that old consoles worked when I refreshed the page but new consoles didn't work at all, which is different to the old one.

Anyway, naturally we'll be working on nothing else until this latest problem is fixed.

@cob -- I'm pretty sure that the multiple-character issue you saw is unrelated, as it doesn't affect everyone (and thank you again for reporting it, it's very helpful). A couple more questions would be really helpful for our debugging:

  1. Does it always happen, or only for certain consoles?
  2. If it only happens for certain consoles, does shift-refreshing the page make it stop happening, at least temporarily?
  3. Does it happen from all locations, or just from some? For example, only from home but not from work?
  4. Do you ever access PythonAnywhere from behind some kind of firewall or proxy? If so, is there any correlation between that and seeing the problem?

All fine for me again - thanks a lot!

Great, thanks for letting us know!

I am a new pythonanywhere user and I am not getting a prompt on the Python 2.7 and IPython 2.7 consoles I opened -- just a blue flashing rectangle and the message "Starting unencrypted connection to consoles-1.pythonanywhere.com on port 80" at the bottom of the console. Using Safari 5.1.5 / Mac OSX 10.7.3. Is this a server issue or is something wrong with my setup?

Sounds like a firewall or proxy server issue to me, I've emailed you privately to get more info.

I am having the same problem. Not getting any console. (I am totally new to python anywhere but I am hoping to see a screen where you can type python commands) Nothing happens. I may be behind office firewall right now but about a couple of hours back I had tried from home as well but I had the same issue from there as well.

Just a note for completeness -- we're talking to alokjoshi over email too, and will post anything interesting that turns up, stripped of any private information, here on the forums.

For what it is worth make sure you are using Firefox not Explorer.

Thanks giles for the pointer. I tried using Chrome and now the Console works perfectly. Pythonanywhere rocks.

Thanks, guys. We should put something on the front page saying that we don't currently support Internet Explorer, I'll get that into the next development cycle.

So things have been working fairly well recently until today. Tonight I tried to start a console and couldn't get one even after waiting 15 minutes. So I tried via another browser window and finally got a console but it immediately froze and wouldn't let me type in anything. So I tried again and got a console but it froze after letting me type 2 letters from a command. This also happened with the next console I got and the next. Now the system said I had 5 open so I killed all 5 in the list and started again. The next one froze and the following one finally let me type a full command, which was to kill a process I had started earlier. But the system said the process didn't exist. In fact it does. So yet again I can't kill a process even though I have the process number. I actually killed the window associated with that process earlier and that is supposed to (and usually does) kill the process. But as happened several weeks ago when I kill the associated window the process continues to run although the system seems no longer to associate the process number of the process with the process and therefore I can't stop it. And, BTW, after the system informed me that the process number didn't exist it promptly froze up. Totally, totally bizarre system behavior and a royal pain in the neck.

Hi cob,

Maybe a bit of explanation will help, Console IDs are in no way related to underlying process ids. If you try and kill a process id (pid) and the system tells you it doesn't exist or you don't have the necessary permissions then I'm not sure why you would believe that it does actually exist. It really doesn't. Honest.

In terms of consoles locking up. They usually aren't locked up. And this usually only happens if the underlying transport has fallen all the way down to XHR-Polling (your browser tries, websockets, flashsockets, and XHR-Polling) which is a bit rubbish to be honest. We only use XHR-Polling if your browser absolutely can't support anything else. But anyway, back to my main point. These consoles aren't locked up. It's just that crappy XHR-Polling has not worked well and you need to refresh the whole page to get it to connect again and start accepting input. The bash or Python console is still sitting there. So yeah, nasty old XHR-Polling requires refreshes sometimes. It's a crappy transport technology and we wish everyone used the latest versions of Chrome and or Firefox so that nobody would ever see it. Even Firefox has issues with websockets. So absolutely the best browser to use would be Chrome at the moment.

Hansel, I'm well aware that console IDs are not related to process IDs. I'm not sure why you addressed that however in your post. And yes I've started processes twice now where I saved the process number for the process and later tried to kill them only to get the system response that the process number I'm trying to kill doesn't exit. Yet I know, given what the process is doing, that it is still alive. Like I said it's bizarre system behavior. It's only happened twice but it has happened nonetheless.

Currently when we deploy a new version of PythonAnywhere we switch over to a fresh cluster of servers. This happens transparently to the user but the underlying bash processes are brand new. Even though the console id is the same the bash process has been restarted. So it looks like the old console but it is a brand new bash shell. This happens about twice a week at the moment but we hope to eliminate it entirely in the future.

Maybe this is what you are seeing? Otherwise I'm a bit confused myself, are you seeing the output of a process that you think you've killed? Is that why you think the process still exists? I just don't understand where you would be seeing it and if you let me know what makes you think your processes are still running then maybe I could have an actual shot at debugging the problem for you. Where are you seeing the output of this process?

Cheers

Hansel

So today I started a process earlier and sometime in the last 3-4 hours somebody killed it. Great. Thanks. Never a dull moment here.

Sorry about that, we had a huge influx of users from an HN post and the server fell over. We are working on a feature to make consoles recoverable after a server crash, though.

Well at least there's an explanation. Not a problem. These things happen from time to time.

One problem-I'm having the same "stray" process problem yet again. You guys are pathetic. This whole project is a mess.

Cob, if you want some assistance with your problem then you should answer the questions I posed five posts above. There is literally no way for us to debug your problem without you answering simple questions. Where are you seeing the output of these stray processes?

I'm sorry you think the project is a mess. We are proud of it and want to make it as good as possible so will be trying to make it work better for you.

And now the latest: I try to run something, the system says it's running but I can see that it is not. Just great. Maybe I should go through the troubleshooting process again and be told that "the system is working" and get absolutely nowhere.

Hi Cob -- as far as we can see the system is working fine. It looks like you have three bash consoles running, one of which is running a program called g5.py.

What is it that makes you think that the program isn't running? If you tell us that, we'll be better able to track down the problem. If there are any confidentiality issues (for example, your program is processing private data of some kind) then you can let us know via the "Send feedback" link at the top of this forum page -- anything you send us there from is kept private and is not posted to the forums.

The OTHER problem with your troubleshooting process is that you seem to think that it is ok for anybody who looks at your forum (which could be ANYBODY at all) to see almost any details whatsoever about account holders. For example, in our troubleshooting session you had me post my operating system version, etc for everybody to see.Stupid of me to post that information BTW. In case you aren't aware of it that is not a good idea. If I have to explain this forget it. Now the fact that I'm running a script named 'g5' is not a security risk. But the fact that you just seem to think that anybody's details here are everybody's business is a problem. Guys if you are going to run this successfully you need to think about things like this. Ironically, you won't let us run the 'ps' command because you don't want people to know what processes each of us is running. Whew!

BTW, in another thread in this forum someone asked why you can't just have a "customized" version of ps which we could run which filters out others' processes numbers so we can only see our own processes. And the real 'kill' could then be used to kill any of our own processes. As the other user suggested this could be done very quickly. For example something as simple as (the real) ps grep <userid> would work as the behind the scenes functionality for the user version of ps. This would be very useful. What's holding you back on this?

Hi Cob -- we take everyone's security and privacy very seriously indeed, and we've thought long and hard about the issues. We never post or encourage people to post anything that we think might compromise either. The "Send feedback" link at the top of every page on the website offers a way that people can send us any information they'd rather not have publicly visible on the forums, and we actively encourage people to use it when they're posting anything private.

We're not aware any issues in establishing a link between a pseudonymous PythonAnywhere user ID and an OS/browser -- after all, all major browsers broadcast by default the much-more-useful-to-hackers link between your IP address and the OS/browser to every website you visit. But if you'd care to let us know what your concern is, perhaps we can address it.

One of my colleagues is answering the question about ps on the other thread.

Finally, you've still not answered the question I asked earlier about why you thought that you had processes running but the system was telling you that they were, and vice versa. Without that information there really isn't anything we can do to help.

Wow