Cannot add CNAME record on GoDaddy for custom domain

So I tried to add a new CNAME record for my custom domain on Godaddy. I entered the following into their dns manager:


Host: www

Points to:

TTL: 1 hour

(I replaced the actual numbers with XXXXXXX)

When I click save, I get the following error on GoDaddy: "There was an error processing your request. Please try again. If this issue continues, contact support."

I called their support. They tried to add the record as well, but it failed. They said to check with pythonanywhere to confirm I am doing it right.

It's impossible for us to tell what is happening inside the GoDaddy system. It's the error generated by GoDaddy not by us.

But does it look correct to you what I am putting in the CNAME record?

I was fiddling around and was able to add the CNAME record. I had to delete out the old CNAME record and then I was able to add the new one.

Glad to hear that you made it work!

from where to get the XXXXXXXX number rename option is not showing

@bharatmobiles you need a paid account to use a custom domain.