Manage. Py check - - deploy gives me that debug is set to true but in my settings debug is set to false check - - deploy gives me 1 problem

Are you sure that that the settings where you have DEBUG = False are actually the settings that are being used or that you don't have a DEBUG = True that is run after the DEBUG = False that you are looking at?

Yes, i'm sure I am using the where i hav set DEBUG = False

If you have two sets of settings, you will need to make sure that the right one is being picked up when you run management commands in Bash. Right now, in your WSGI file, you probably have something like this:

os.environ['DJANGO_SETTINGS_MODULE'] = ''

That will mean that your website will use the right settings file, but you will also need to specify that when you start Bash consoles, by running


thanks, My problem is solved by running first the export command


before the

./ check --deploy thank you for your help

OK, glad we could help!