Installing flask markdown extension

Hey all,

While I was deploying my Flask app on PythonAnywhere (awesome!), I had a small problem. I installed few extensions such as flask-admin and flask-login via easy_install. And I did the same for flask-markdown. But it did not work for flask-markdown (only)!

18:44 ~ $ easy_install --user flask-markdown                                                                                                                           
Searching for flask-markdown
Best match: Flask-Markdown 0.3
Processing Flask_Markdown-0.3-py2.6.egg
Flask-Markdown 0.3 is already the active version in easy-install.pth

Using /home/jadez/.local/lib/python2.6/site-packages/Flask_Markdown-0.3-py2.6.egg
Processing dependencies for flask-markdown
Finished processing dependencies for flask-markdown
18:45 ~ $

The installation looks like it's fine... so what's wrong?

import mardown # This is ok
from flask.ext.markdown import Markdown # This fails while the exact same line works on my local machine

Any input is really appreciated :) Thanks a lot :D

Ok, problem solved. The whole python2.6 /2.7 thing mixed it all up. I was trying to import it from py2.7, while it's installed on py2.6. What's weird is that the others worked... but not that one...

Thanks anyway :) Viva PythonAnywhere.

I ran into this when installing Flask_Mail and this post helped me out. Thanks jadez!

@melt: Welcome to PA. We're glad you found us...☺