virtualenv + Django 1.4.1 but it's still using 1.3.3

I'm trying to use Django 1.4.1 so I did this and verified that Django 1.4.1 worked in the shell. I then changed my file to this and reloaded my web app but I'm getting errors with Django 1.3.3 paths like this:

"/usr/local/lib/python2.6/dist-packages/Django-1.3.3-py2.6.egg/django/core/handlers/", line 250

Full traceback here

Help please, I have been stuck for a couple of days trying to figure out how to get this to work. Thanks in advance.

Just to confirm, you have reloaded the web app from the 'web' tab of the control panel...

Yes, and got that error message in the log and the site displayed the "unhandled exception" message. Since then I've reverted back to 1.3.3 until I can figure this out.

The problem was this line

mkvirtualenv --python=python2.7 django141

which should be using python2.6, like this

mkvirtualenv --python=python2.6 django141-26

Of course, then you'll also need to change the location of your virtualenv in

I would suggest keeping your Python 2.7 virtualenv around because some time next week, we're going to upgrade webapps so that they use Python 2.7 and then you can just switch your back to using the Python 2.7 virtualenv.

Yep, as Glenn says, we're now on 2.7

hello i have the same problem. I performed that you wrote, but the problem is not decided.

i have the same traceback and message on site. Could you help me??

How did you create your virutalenv? Remember, as Hansel said, we're now on Python 2.7, so the correct way is this:

 mkvirtualenv --python=python2.7 django141

it works now...