Certificate and key do not match.

Hello, I've read your documentation on installing an ssl certificate followed the steps but it keeps bringing the "Certificate and key do not match." error, in key I used the private key generated when I request the CSR, then I downloaded my certificates, combined the first certificate then add a new line and paste the chain. No idea why this is not working. Any ideas? (btw, I bought the ssl certificate in godaddy)

Well, I've finally figure it out. Please read carefully . For some reason the private key that godaddy gave me was somehow broken so I requested a rekey and made the CSR request following the steps from the link above. Then tried again but now with the New key and BOOM, it worked! Solution:

openssl req -new -newkey rsa:2048 -nodes -keyout -out

replace yourdomain with your actual domain name, no need to add www when prompted common name type down your domain name, in my case was , don't forget to add the www

OK, glad you worked it out! It's worth noting that we can provide you with free HTTPS certificates using Let's Encrypt with just a couple of clicks -- see this help page -- so there's no need to use a custom one from GoDaddy or another provider unless you particularly want to.