no minus sign in consoles

I am stumped by a strange phenomenon I observe for the first time in the consoles: I cannot type a minus sign "-" anymore. If I do, the cursor simply stays where it is. So, after typing "a=2-1" the display will show "a=21".

It's not a keyboard issue; the minus key works fine. Also the consoles only refuse keyboard entry of the "-". I can still type a line containing a minus sign elsewhere on my desktop and copy/paste it into the console.

This issue affects ALL consoles: Python, MySQL, and Bash.

I don't know if this is relevant, but a few days ago I started to get Windows error messages whenever I tried to initialize new consoles in Firefox, This concerned a supposedly bad install of the Apple Quicktime plugin. These messages would pop open 4 times every time I would start a new console. After that, everything would work. Still, it was annoying, so I reinstalled the latest version of the Quicktime plugin, 7.7.2. This took care of the error messages, But that also seems to coincide with the time that I started to notice this issue. I am running Firefox 15.0.

Does anyone else notice this, or have a solution?

Just to add a little to the mystery: The minus sign on the numeric keypad works fine. It's just the one between '0' and '=' at the top row of the US keyboard that seems affected.

Also: Just tried Chrome (version 21.0.1180.83 m) instead of Firefox. No problem there. The issue seems to be confined to FF

I've just tried both a bash and Python console and I can enter hyphens without a problem. I'm using Chrome 21 on Windows 7.

EDIT: Ah, you found out Chrome works yourself. Well there's your answer. Firefox is too bloaty these days anyway... (^_^)

@catweazle: I agree this is an issue on FF. I have the issue on ver. 16.0a2 (2012-08-24). If the forum had search capability, I would have linked to where this has been mentioned before.

@Cartroo: Yes, FF is bloaty, but Chrome doesn't have a vibrant enough extension network YET.

@a2j: Actually, I was pleasantly surprised how easily I made the transition a couple of years ago. At first I thought I was going to miss the million or so extensions I'd installed, but I very quickly found out that most of them were just things I thought would be cool but quickly fell fallow.

All I really need from a browser is AdBlock, but since moving to Chrome I've found Speed Dial 2 has become more or less essential for me. Panorama is certainly very nice, but Tabs Plus is a passable replacement, and Tab Cloud is also rapidly become something else I rely on when I need to context switch at work. I have a bunch of others installed, but the only other one I would hate to lose is Lazarus, although that one is available for Firefox as well. It's saved me losing long edits to wiki pages many times in the past (especially as the wiki at the previous company had a tendency to log you out while you were in the midst of editing a page).

@a2j: Just found your post here. Sorry to duplicate threads. I didn't read back far enough.

I noticed that when I am trying to start a bash console, the console shows me only one line. Killing the console does not help. Also restarting the browser does not resolve the problem. I am using Chrome as browser because FF has the issue with the _.

Has anyone seen this issue and found a way to to get it resolved? It's really annoying ...

Hey Roman,

Yup it took us AGES but we figured out what was causing this problem. It's the zoom level on Chrome. Try doing "Ctrl 0" to reset your zoom level to the normal.

Cool :-) Thx for the feedback

@Cartroo: You don't run ScriptNo?

@ catweazle: Yes, that's the one. Thx!! I scanned past it looking earlier. I forgot that was the topic for the conversation.

@All: For those with paid accounts. You can always SSH in and the "-" problem doesn't exist there either.

@a2j: No, I don't. I used NoScript for awhile in my Firefox days, but the web just became too damn annoying to browse without Javascript. I prefer to focus my security efforts at limiting the browser's access to the system as an application, which I regard as a more reliable protection anyway (since it also catches bugs in HTML rendering engines and the like). On Windows this typically involves sandboxie, but so far I've managed to convince myself that Chrome's built-in sandboxing is probably just about good enough so I've just been running it native.

Anyway, once you isolate the application from the system, malicious scripts can't do a lot of harm except steal session cookies and the like - since I always open a separate Incognito browser instance to access sites such as online banking, I don't regard this as a particularly troublesome threat.

If you're thinking less about security and more about sites using Javascript for annoyances, I simply stop using sites that annoy me.

I find AdBlock plus is pretty good at getting rid of the bulk of the most annoying JavaScript.

I forget if we've requested it or not, but adding a feature to the forum that allows us to fork a conversation rather than hijack it (going OT) would be nice.

Or maybe like SO does it where you can post either an answer or just a comment on any of the answers (or original question).

(pending the ability to fork conversations) @catweazle -- I'm seeing that issue too, Firefox on Linux. But glenn has a windows box, and he can type hyphens just fine. Which OS are you using?

For me I've confirmed the trouble on two platforms.

  1. FF 16.0a2 (2012-08-24) {Aurora Channel} on Windows 7 x64 Home premium ver. 6.1 (Build 7601: SP 1)
  2. FF 16.0 {Beta Channel} on Windows Vista x64 Ultimate ver. 6.0 (Build 6002: SP 2)

Previously I had verified it on Some form of both FF 14 and FF 15 as well.

I just verified the problem continues on FF 17.0a2 (2012-09-01) {Aurora Channel}. Not that I expect this to surprise anyone.

Hmm, I use the regular Firefox day-to-day (Chrome keeps annoying me by losing the thousand-or-so open tabs I use to keep my mental state, Harry tells me that perhaps that's not the best way to organise things, but he's wrong) and haven't had any problems. So perhaps it's a bug coming down the line in the next version -- thanks for the early warning! I'll switch to the beta channel tomorrow and see if I can repro it.

I thought I was bad averaging 100 tabs. It's good to know there is hope for me yet!!

@giles: I use TabCloud to save my tabs in Chrome, organised into different windows by context. Unless you're accessing all thousand of those tabs concurrently, you might find it works.

I've heard about Chrome losing tabs, but I must admit I haven't seen it myself... Do you mean it just random crashes, or fails to restore tabs on a restart? The latter I can quite believe because I'll never bring myself to trust a browser with that (had exactly that same problem myself when I used to use Firefox), but I don't believe I've ever had a crashing issue in Chrome over the past couple of years on either Windows or Mac.

Yup, Chrome was failing to restore them on a restart. Firefox crashes much more often, but I've never (crosses fingers, touches wood) had it fail to restore them, at least not since I stopped trying to run with dozens of different profiles. TabCloud looks pretty nice, though -- I'll give it a go, thanks!

@giles: I've only been using it a few weeks, but it hasn't lost any saved tabs yet... It doesn't have any sort of "auto-save", however, so you do have to remember to do a manual save every time you exit or context switch.

It's been a few years since I last used FF, so perhaps they've fixed the bug I used to run into. A period of unreliable power at the last place I worked shook me of the habit of relying on too much local context, whether that's browser tabs, terminal windows or anything else. I use a combination of bookmarks, Speed Dial 2 and TabCloud to make sure I have important URLs recorded, and my workload is tracked with Omnifocus (the only "to-do" tool I've ever found which doesn't actually increase the net effort required).

To track the time I spend on tasks, I use a simple command-line tool which I wrote ages ago. Of course I'd forgotten about it until just now, which is ironic because in my new job we're asked to track estimates and actuals for everything, whereas the place I was working when I wrote that tool it was just for interest.

OK, we have a fix to the problems with minus signs and underscores in Firefox 15 -- you'll need to shift-refresh any open browser tabs to activate it.

However we did get one report (over the feedback link) of a problem where typing "a" could lead to "Aa" appearing in the console, and so on for other keys. We saw this when running under Firebug while trying to fix the underscore/dash issue but haven't managed to get it to happen since. If you do see it, please let us know -- we'd love to get it fixed!

I can confirm that "-" now types correctly in FF 17.0a2 (2012-09-02) {Aurora Channel}.

I went on to attempt trouble with alpha characters, but was not able to duplicate.

Excellent, thanks for confirming that a2j! Let's hope it stays fixed now.

And @Cartroo -- I just rely on my email inbox, which normally (except when I'm lazy) is just a gateway to Remember the Milk tasks for myself and Trac for our team issue tracking. And those thousand-or-so tabs...

@giles: I know a few people who use inbox systems, and it works for them. At my previous job I typically had something like 10-12 background tasks going on at once and I couldn't find an email client that handled filtering well enough. I'm not saying this is a healthy way to work, but that was the way it was. Also, I'm not talking about bugs and other development tasks - they were tracked in the bug tracker and that worked fine. I'm talking about other stuff.

Omnifocus lets one assign both a context and a project to a task, where a context is something like "in the office" or "out shopping". You can then set up custom views so it only shows you tasks that you can get on with right now without having to wade through tons of things which aren't relevant. It's also got a handy notion of an inbox where you fire tasks you haven't yet had time to categorise or assign a deadline and a handy global shortcut for adding them.

It's designed to work in a way compatible with GTD which essentially says that to reduce stress you should never rely on holding things in your memory. You delegate all your tasks to a reliable system that you trust (could be software, index cards, a diary, anything). It works well for people (like me) who quickly forget things on which they're not immediately working and for whom remembering to do something later involves constantly reminding yourself and losing concentration in the process.

Sorry, that was quite a long off-topic ramble, but it really did make a massive difference to the way I worked. It's pretty expensive, it's more powerful than a lot of people will need and it's iOS / OSX only; but for anyone who's struggling under a massive backlog of tasks, I'd really recommend looking into it. I looked into a lot of todo-list applications and nothing else came close.