Can't edit file anymore

Hi, when I try to edit a file the formatting is all gone and the entire script is one line.

ya there is something wrong with the server even my website taking for ever to loads !!!!

@numandina for the formatting stuff, was the file uploaded? could it be a windows/mac/linux new line difference? note that we are on a linux machine, and I see that you have a bunch of .exe files.

no i am sure it's a problem on your side , the bash is not working the editing of the .py files is not working , my website is not loading completely, i don't know what is going on

Hi Sosolo,

I just went to your account console page and started two consoles in bash and in python, and there doesn't seem to be a problem. ie. the loaded and I could type into them and get results etc. Could you give me more details?



I want to edit one of my files but when clicking on it I cannot change anything and it is formatted incorrectly, like this picture shows:

I tried this on all browsers. I am operating on Windows and used to edit files all the time previousl.y

@numandina can you try again? it turns out that one of our servers had filled up all the space allocated for logging- I'm not sure if it has to do with your line ending problem, but let me know if there is any difference.

@sosolo- that should be the console loading and website slowness problems you experienced- very sorry for the inconvenience :(. I visited your website and it loads pretty snappily now (<1s). Please let me know of anything else.

No, this was a problem with the server, editing files gave a javascript error for one of the resources for editing files.

I quit for a while, and cleared my cache and it seems to be ok now, but this was definitely a server error as there are several bugs that report the same activity I had: e.g unable to edit, unable to access console, unable to load webapp page.

I am still unable to edit/view/run my files from the Files tab.


I have the same problem, I am running on Mac OS X Yosemite 10.10.3 with Chrome/Safari browser.

Have you tried reloading / deleting your browser cache? (Sorry if it's a dumb question) What is the file that you are trying to edit/view/run?

I have files only with extension .py and .html, so these files. But as you said, clearing cache helped me :)

I didn't delete the cache but everything is fine now.


Same thing occurred when a txt file (json) is higher than 1.50 mb, to fix the problem, in a way I separated the file into several parts .