PythonAnywhere Forums

right parentesis don't work on console for azerty keyboard

I have an azerty keyboard but I'm afraid that the right parenentesis key don't work on the console I speak of this character ")"

Could you provide more information on your OS and browser? Without knowing that we could have a lot of recommendations that won't be helpful such as suggesting you type <ALT>+<41>.

I'm under fireox+ubuntu unfornutaly <ALT>+<41> doesn't work as ALT is intercepted by the console

Unfortunately do have some issues with different keyboards layouts. We haven't spent a lot of time debugging it. I've tried to get more information about what char codes these keyboards are sending and trying to work out where the problem actually lies but that hasn't worked. It's always hard to figure out what is going on without having the device physically in front of you.

Can you tell if the keyboard is actually sending char code 41 to the terminal? What happens if you change to a different keyboard layout?

@xcombelle: Great news...hansel is on the case. That usually means your problem is nearly resolved...☺

Hi again xcombelle,

When I switch my ubuntu machine to using the "Belgian (Wang model 742 Azerty)" keyboard layout the key immediately after the '0' sends a ')' without using SHIFT. Is that the keyboard layout you are using?

The Alt key on the right of the space bar lets me get a '\' from the same key and SHIFT gives me a '°'. That right Alt key shouldn't be getting captured by the console.

it's a french one but it is the same place for ')' the right alt key give me ']' which is not captured by the console. the right alt key at the 5 give me '[' which is correctly captured by the console

It's very weird and why it's been very difficult to debug this issue the few times that it has come up. My only conclusion is that something is different about your actual keyboard hardware. When I change to any AZERTY layout and press the '0' on my das keyboard it sends a ')' to the console. As it should. That's the whole point of keyboard layouts. Make and model?

when I change to qwerty layout (us under ubuntu) the minus sign doesn't go to console it's the same key my keyboard is the built in keyboard of a laptop aspire 5738Z

I just discovered a problem with the same (minus sign) key in a bash session via browser using Windows 7 and FF 16.

it's defintly a bug in FF 16 I tried in Chromium and it perfectly works

Ah, okay that would explain why I wasn't seeing it in Chrome or older FF versions. Thanks for all the information. We should be able to repro it now.

When the source of the bug being catched that would be cool to raise a bug on mozilla. better than having a workaround

I informed Mozilla about the issue as well.

I might have a similar issues using Mac OS X 10.7.4: On any browser (Safari 6.0, Frefox 15.0.1, Chrome 21.0.1180.89) I run into the issue that my iPython shell won't accept square brackets using a Swiss French keyboard. The key combination that produces them pretty reliably outside of the shell would be ALT+5 for [ but it just doesn't work. Any ideas?

@lwieneke: I really think that we're going to have to implement something to diagnose these issues. There are too many different combinations of language, browser and OS for us to exhaustively test them all. So we're going to have to rely on our users to help us out. I'll post in the forums when we have the diagnostic tool ready.

@lwieneke: Welcome to PA. I wish you the best time in this community!!

@all:

Living on Earth is expensive, but it does include a free trip around the sun.

Birthdays are good for you - the more you have the longer you live.

Here I am! What are your other two wishes?

@glenn: I'll keep an eye on the forums and will be glad to help! @aj2: Thx!

Hi there, for anyone else struggling with azerty or other non-english keyboard layouts, we just released an experimental fix. Let us know if you would like us to switch it on for your account.