Getting one file from git repository

Hi Sorry about this but I am stuck again! I have been making changes to a single file on my local machine and done git add and git commit for that file (facilities_list.html). These changes have been successfully committed:

nicka_000 (master *) templates $ git add facilities_list.html
nicka_000 (master *+) templates $ git commit
[master 46e24e9] Add working map with auto lookup on address
2 files changed, 213 insertions(+), 5 deletions(-)
create mode 100644 templates/places_search.html
nicka_000 (master *) templates $ git log
commit 46e24e99eb5e25dc6b064e8516db4b1a180ef039
Author: lz7cjc <>
Date:   Wed Mar 4 10:30:32 2015 -0500

Add working map with auto lookup on address

commit e18fe2298a482113da218c7e18944503223d309f
Author: lz7cjc <>
Date:   Wed Mar 4 09:41:03 2015 -0500

Add Journey planner outline section - pre adding code

commit ffdb60e29a5444a40f125ee1bc8bfd961e80fce1
Author: lz7cjc <>
Date:   Tue Mar 3 06:40:05 2015 -0500

Bikes switched off by default and only show facilities under £10

commit e497df918dffbf10110387d7e84be7231aaaa6f1
Merge: 589c6fb c23825e
Author: lz7cjc <>
Date:   Mon Mar 2 21:07:05 2015 -0500

I then went to the bash console and tried to do git pull and git pull facilities_list.html but was told there was nothing to pull.

Facilities_list.html is in the sub folder: templates.. so i tried doing that from the recharge root folder and also from the sub folder.

Where am I going wrong?

thanks Nick

after you git commit on your local machine you need to git push to a remote repository (eg: github/bitbucket)

make sure you have your local machine git repo setup to track the remote repo, and also make sure that your pythonanywhere git repo also tracks the remote repo.