Forums

Unable to install TA-lib on pythonanywhere

Hi guys,

I have been working on a project that requires the talib module but it cannot be installed on the server. So far I have tried,

  • easy_install --user TA-lib
  • pip install TA-lib --allow-external TA-lib --alow-unverified TA-lib

but none seems to work.

Does anyone has the same problem?

Have you tried the second command (the pip) with the --user flag? What error did it give you?

i am having the same problem using pip or easy_install

Looks like we need to install the ta-lib library. We'll try to get that into the next update in a few weeks.

Thanks, Glenn. Looking forward to the update.

...and it's installed now. Let us know if how it looks to you!

Thank you, thank you, thank you! I'll try :3

pip install TA-lib --user worked for me

Thanks for confirming that!

What am I missing ? Running default python (3.9) pip install TA-lib --user (Seemed to go ok?) But in a .py script testing it:

import talib
print("testing")

Error:

Traceback (most recent call last):
  File "/home/pladekusken/Repo/Ticker/main.py", line 1, in <module>
    import talib
  File "/home/pladekusken/.local/lib/python3.9/site-packages/talib/__init__.py", line 93, in <module>
    from ._ta_lib import (
  File "talib/_ta_lib.pyx", line 1, in init talib._ta_lib
ValueError: numpy.ndarray size changed, may indicate binary incompatibility. Expected 96 from C header, got 80 from PyObject

Try upgrading the version of numpy.