Error Log: ImportError: No module named myname_pythonanywhere_com_wsgi


I was running Django 1.5 inside a virtual environment with the same code for a little over a year. Today when I checked the site, I received a "Something Went Wrong" PythonAnywehere error page. When I checked my error logs, it showed ImportError: No module named myname_pythonanywhere_com_wsgi as the error being thrown.
I'm able to run my wsgi file with the Python interpreter as suggested by the Help docs and I'm able to import my settings etc. within the shell.

In an effort to get the site back up, I ran 'lsvirtualenv'(I forgot the name since it has been so long) and it returned none! So it seems my virtualenv was deleted somehow. I created a new virtualenv and installed Django 1.5 in it and edited my wsgi file to represent the new env, yet I still get the same 500 error code.

Any thoughts on resolving this?

Sorry about that. It looks like your execution environment got into a weird state on that particular web server. I've rebuilt it manually, so things should be working now?

We'll see if we can figure out a root cause and/or a more general fix...

Yup! Everything is working again. Thank you,

I have this error too. Worked fine a few days ago but now it says

2014-10-28 22:43:00,108 :ImportError: No module named thecutestthing_pythonanywhere_com_wsgi

Looks like it's working now. Did you work out what the problem was?

It works now! I don't know what changed.

Hello, I am not able to import xmltodict in the current project. how i can make it working?

Have you installed it? Help here