Cannot connect to server ( by svn

I can use it before, but I found I cannot access it today.

I use 'svn up', and it return error message like the title.

I try the svn checkout to the other place, the same error message returned.

I cannot use ping/telnet to see whether the network error or something wrong .

BTW: I can access the site from home.

We implemented a block for free accounts to prevent abuse by our users. We added a large number of exceptions for sites that we think are generally useful to our users. assembla wasn't one of them, but it looks like a good one for us to add. I'll add it now. It should begin working again in about half an hour.

What do you think of publishing this exception list?

My reason for interest is to perhaps learn about sites/services others are using that I don't know about, Where the free account users would have the list as a reference to where they can connect.

First, I appreciate your work for free user. Indeed it should prevent the abuse.

I suggest the reputation system bad one should prevent harder and harder.

I couldnot access the site now, but I get around it by file upload function.

Thanks anyway.

@a2j: We do intend to publish the list. We just didn't get to it this time around.

@liquninfo, that was an oversight on our part. Subversion needs specific config to use the proxy. Edit the file#


it starts off as mostly comments. Towards the end you'll find the


section. Edit it to look like this:

http-proxy-host = proxy.server
http-proxy-port = 3128

and your checkout should work. We'll do that by default in future.

NOTE: This is specifically for Free accounts. It will make your Premium/Hosting account behave like a Free account if you do it in a Premium/Hosting account.

Great, it is ok! Thanks!

Another like post, I am trying to svn checkout with codespaces. The url I am using is

I get an error "could not create SSL connection thru proxy server... "

How can I checkout?

@ccoovrey, since you're a paying customer, you don't need the proxy setup in the .subversion/servers config file. In fact, it will prevent subversion from working with sites that we don't allow for free accounts. If you have http-proxy-host and http-proxy-port set up as described in my post above (I should have made it clear that this was only for free accounts), just delete those settings.

It may also be that your console is left over from when you were a free user and it still has the config from then. If that is the case, start a new console to get the config for a paying account and it should work.

I'm still getting the error message "could not create SSL connection through proxy server 403 forbidden"

Looks like there's something weird going on with our subversion config. Try this:

svn co --config-dir /home/ccoovrey/.subversion

I'll carry on investigating to find out why that's necessary.

it works for both checkout and commit, but for every svn action I do I have to put in the --config-dir ~/.subversion. If you can find out what I need to do (maybe in some config file) so I don't have to do this everytime, it would be good. Thanks.

I worked it out. There's some code missing that should clean out the config from when you had a free account. We'll get that fixed soon.

We've just finished the fix for this. It should be available later in the week.

Yep, that's fixed now - let us know how things look?