Scheduled tasks not running

I have scheduled hourly tasks, but for some reason I can't get them to run. I have tried removing the task and adding it back. I have tried running both a Python script and a bash script. Nothing I do seems to make a difference. The log for each file simply says:

Task has not been run yet

Just to try, I also added a Daily scheduled task which also failed to run. Right now I have a bash script scheduled to run. It's executable and has the proper hashbang. Before the bash script I tried a Python file, also executable. I searched the forums prior to posting and it seems there was an "intermittent bug" with the scheduler sometime back in May. I'm not sure if this is what I'm experiencing, but I've been trying for the last 8 hours without getting anywhere.

Is it possible that they were running but weren't showing as running on the "Schedule" tab? I've looked through the logs, and it looks like there was a problem displaying your running tasks last night. Or do the tasks have a side effect that you could see wasn't happening, so you know for sure that they weren't running at all?

Yes, I know the scheduled task didn't run because it's a spider and nothing has been added to the database other than the times I ran it manually.

Hmm. Have these scripts ever run as scheduled tasks? Or only from the command line?

Ah, hang on -- I think I've spotted something odd about the way your account is set up for scheduled tasks. Investigating.

Got it! There was a weird problem with the way virtualisation worked for your account -- not sure how that happened. I've fixed it, and one of your tasks is running now. Sorry about that!

Just saw that the first scheduled task ran and it worked perfectly. Thanks a lot for the prompt response.

No problem, thanks for confirming it's working!