Any idea why SSH is failing?


I am having difficulty with some simple SSH-related tasks that normally work. When I try to clone or pull from a git repository, I get:

fatal: Could not read from remote repository.

Please make sure you have the correct access rights and the repository exists.

...and when I try the normal ssh command (ssh, it will connect, then immediate display Connection to closed.

I tried clearing out my .ssh folder, but these errors still persist... any ideas? Thanks.

I'm having the same issue.

FWIW, I'm connecting OK at the moment to using SFTP/SSH on port 22, using a Windows client (Ipswitch WS_FTP Pro).


That's strange. It's working from here too, from Ubuntu.

What do you see if you run ssh with the -v option, eg.

ssh -v


If you're worried about any private data in the output, you can send it to us via the "Send feedback" option at the top right.

Many thanks to one of our users who just sent in the results of the ssh -v, we've tracked down the problem. It should work now -- let us know if it still doesn't for you.

I just checked it out, it appears to be working again! Thanks a lot

Excellent, thanks for confirming that!