I setup a new CNAME with my domain provider but isn't detecting it

I followed the tutorial for deploying Flask app on where I was instructed to log into my domain provider's site and set CNAME record to point my domain to It took all day for the change to take an effect (I kept checking the status) and it's still not working. The domain provider confirmed that my site is pointing at but when I click on "reload" in the Web tab it still says "You do not have a CNAME set up for your domain.". The domain provider clearly says that I do.

What should I do ?

This help page has a "Testing your configuration" section you can try.

Hi Glen. Way ahead of ya on this one. I'm just getting red crosses across the map and that's it. I'm not getting any specific errors. That's why I created a post here 'coz I simply don't know what went wrong. I think I followed the guide correctly. It's pretty straightforward and yet my Flask app is sitting on the server not being connected.

If you're just getting red crosses then either the CNAME is not correctly configured, or it needs more time to propagate.

The domain provider states that the CNAME has been updated. It did take all day though. Now it says: "This CNAME record will point to" Which looks correct to me. When I click on reload I get error saying I have no CNAME configured. What gives ? I'm really confused.

Your web app is, not Rename it to match the CNAME.

I hope that's not what's been wrong with it. That would be silly. Will try. Thanks for suggestion !

Well, here I'm 2 days later and it still says the same error. So my Flask app has been ready to be served all this time and after following the steps 5 times over it's still not working. I've deployed websites before and I used my dedicated Ubuntu server to serve it. And I never had problem with serving websites on Apache. This is the first time I'm having third-party to serve it for me and such headache. I'm really sorry that I'm having this experience 'coz otherwise the is absolutely amazing ! Especially if you're coding on Chromebook.

It looks like you've broken your CNAME now. Review the documentation here and here to make sure that your CNAME is correctly set up and that your web app is correctly named.

On these pictures you can see what I'm getting. An error from web tab and how my domain is being pointed to

Can you see anything wrong ? I appreciate anything that will point me (pun intended) in the right direction.

If you read the text on your domain name config, you'll see that you've configured a CNAME for Put www in there and change the name of your web app to

I had it there before, glenn. But I will change it back. Didn't work. Will take a screenshot once the change is in effect.

This is how it supposed to look like, right ?

Sounds right. You also need to change your pythonanywhere webapp from to

Nice one, conrad ! It works now. Thank you so much !