Forums

SSL Challenge Validation Failed

Hello,

I am attempting to install SSL for my personal domain through Let's Encrypt, but the challenge validation continues to fail on the second to last step. Can anyone please help me out? Thanks!

10:44 ~/letsencrypt $ ~/dehydrated/dehydrated --config ~/letsencrypt/config --cron --domain www.xterns.com --out ~/letsencrypt --challenge http-01 /# INFO: Using main config file /home/divdasani/letsencrypt/config + Creating chain cache directory /home/divdasani/letsencrypt/chains Processing www.xterns.com + Creating new directory /home/divdasani/letsencrypt/www.xterns.com ... + Signing domains... + Generating private key... + Generating signing request... + Requesting new certificate order from CA... + Received 1 authorizations URLs from the CA + Handling authorization for www.xterns.com + 1 pending challenge(s) + Deploying challenge tokens... + Responding to challenge for www.xterns.com authorization... + Cleaning challenge tokens... + Challenge validation has failed :( ERROR: Challenge is invalid! (returned: invalid) (result: { "type": "http-01", "status": "invalid", "error": { "type": "urn:ietf:params:acme:error:unauthorized", "detail": "Invalid response from http://www.xterns.com/.well-known/acme-challenge/BAUm9yk0_DIKJwAG5UYl6TORZm4RaiKXU_8yV_xe7M8: \"\u003c!DOCTYPE HTML PUBLIC \\"-//W3C//DTD HTML 3.2 Final//EN\\"\u003e\n\u003ctitle\u003e404 Not Found\u003c/title\u003e\n\u003ch1\u003eNot Found\u003c/h1\u003e\n\u003cp\u003eThe re quested URL was\"", "status": 403 }, "url": "https://acme-v02.api.letsencrypt.org/acme/challenge/tv8KnlCOJyt6el8UdQOR8WfIIj46088ACwEUy8wcd5k/9853855786", "token": "BAUm9yk0_DIKJwAG5UYl6TORZm4RaiKXU_8yV_xe7M8", "validationRecord": [ { "url": "http://www.xterns.com/.well-known/acme-challenge/BAUm9yk0_DIKJwAG5UYl6TORZm4RaiKXU_8yV_xe7M8", "hostname": "www.xterns.com", "port": "80", "addressesResolved": [ "35.173.69.207" ], "addressUsed": "35.173.69.207" }, { "url": "https://www.xterns.com/.well-known/acme-challenge/BAUm9yk0_DIKJwAG5UYl6TORZm4RaiKXU_8yV_xe7M8", "hostname": "www.xterns.com", "port": "443", "addressesResolved": [ "35.173.69.207" ], "addressUsed": "35.173.69.207" } ] })

You've either left password protection on for your site, or you haven't correctly configured your static files. Check both of those carefully.

Hi glenn, thanks for your reply. I followed the instructions verbatim, configured the static files exactly as specified, and have never enabled password protection. I have also searched this forum, but cannot find anyone with the same error that I am receiving. I tried resetting everything and following the instructions again, yet am receiving the same error. Please advise!

The instructions work when they are followed. Make sure that everything is correct. In particular, I would suggest carefully checking spelling in your static files configuration. Including case.

Thanks for your help, glenn. I managed to get it to work after I reloaded the web app twice after creating the static file configuration. However, Google chrome still displays the 'Not Secure' tag by my website. Can you apply the SSL to my website (www.xterns.com)? Thanks!

Nevermind, I've got it all set up. Thanks again, glenn!