Problem installing python-allauth

Hi guys, After i install django-allauth i get the following error:

Traceback (most recent call last):
File "", line 2, in <module>
from import execute_manager
ImportError: cannot import name execute_manager

From what i read on:

that error don't have to occurs in django 1.6 and up.

from what i see, but i am not shure, the (that was created by pythonanywhere web interface) file look like older version of django.

Someone know how to solve that problem ?


*the error occur during suncdb

Hi reuven -- I guess you're using Python 2.7 -- our system has the rather old Django 1.3 installed for Python 2.7, and uses Django 1.6 for Python 3.3. We're working on a way to fix that without breaking all of our users' existing web apps using the older version.

You can use Django 1.6 on Python 2.7, though -- you just need to use a virtualenv. There are instructions on how to do that here.

but on django 1.3 execute_manager has to work fine. it was deprecated just in 1.4. or i miss something ?

i did another test. i run : import django django.VERSION

inside my app and get: (1, 6, 4, 'final', 0)

i solved that by the following code replace:

instad of:

!/usr/bin/env python2.7 from import execute_manager import imp try: imp.find_module('settings') # Assumed to be in the same directory. except ImportError: import sys sys.stderr.write("Error: Can't find the file '' in the directory containing %r. It appears you've customized things.\nYou'll ave to run, passing it your settings module.\n" % file) sys.exit(1)

import settings

if name == "main": execute_manager(settings)

i put:

import os import sys

if name == "main": sys.path.append('/home/my-username') os.environ.setdefault("DJANGO_SETTINGS_MODULE", "my-project-name.settings") from import execute_from_command_line execute_from_command_line(sys.argv)

maybe you know why that problem occur ?

It's really hard to read your posts. Can you fix the formatting? There's a link at the bottom of every page that explains how markdown works...

Have you guys fixed the problem yet i keep getting an error as well when using the django allauth using 2.7

Are you using a virtualenv?