Pushover module

Hello! Just found pythonanywhere and I'm loving it so far. Love the work you guys have done.

I'm working on a project that uses and yes I'm lazy, I'm using the library I added the "custom" module according to the documentation here and everything reported successful. However, when trying to implement with "from pushover import Client" the interpreter says: "ImportError: cannot import name 'Client'". I have double checked my code and verify the code on my local machine.

Any ideas for what might be going wrong? If I need to provide any more information, please let me know what you need. Thank you in advance for any help you can provide! :)

Hi there, the first thing to check would be -- are you sure you've installed pushover for the right version of Python?

Hey Harry! Great question. That’s what I thought too. I read that the default when running a script is 3.6 so I made sure to run pip3.6 when installing. That didn’t change anything, so I tried targeting v3.6 directly with: “#!/usr/bin/python3.6” in the script. Still no luck.

Quick note, this morning I did notice that it seemed to install somewhat for when I opened a python3.6 console and tried “>>>import pushover” it worked and didn’t error as I would expect if the package didn’t exist. However when trying to initialize the Client, it gives the same error as before.

Many thanks!

Just to make sure, try installing pushover again, with a

pip3.6 install --user python-pushover

Alright so I did that. It said that the requirement was already satisfied. So I removed it and reinstalled it. No luck. Same issue. I've tried to attach some screenshots just for reference. Thanks for your help!

Uninstall / Reinstall - Same Issue -

That's odd! I wonder if it's picking up the wrong pushover module. What happens if you do

import pushover


Hey Giles, you’re right, it looks like it was picking up a different pushover module. I guess I must have typoed (a different valid pushover module) the install the very first time without realizing it. I tracked down the “other” module, unsintalled it and everything is working fine now.

I’m really sorry to have wasted all your time. I really appreciate your help in uncovering my mistake.

Thanks so much! :)

Edit: For reference, this is what your code returned


Excellent -- glad we were able to get to the bottom of this.