Forums

Is it possible to install/run Heroku commands in PA?

Hi! First of all I just started 2 days ago in the free plan and I love everything! Thanks for developing PA. Now, I'm just wondering if its possible to install Heroku. I am planning to manage my Heroku and Git in the command line... Any info would be appreciated. Thanks!

If the package is something you can install using pip, then yes, definitely, it should be doable -- check out this help page on installing new modules.

@giles Hi there! thanks for the fast reply :)

I've got this doc from Heroku installation $ wget -qO- https://cli-assets.heroku.com/install-ubuntu.sh | sh

Heroku CLI

Well, since you said only pip packages work. I'm gonna move on and give up trying LMAO

Hmm, that might actually work -- have you tried it?

Yes, I've been trying it out since this afternoon (South-EastAsia time) :P

I'm suspecting 2 factors: (I'm not quite sure, I might be sharing wrong info here in the Forums)

1) I think PA doesn't allow me to install because I am not root/Administrator or I have access denied (bottom-line is i can't run *$ sudo*)

When I tried running another method to install Heroku, found in their docs: *$ npm install -g heroku-cli*

npm ERR! Linux 4.4.0-83-generic
npm ERR! argv "node" "/usr/bin/npm" "install" "-g" "heroku-cli"
npm ERR! node v0.10.37
npm ERR! npm  v4.3.0
npm ERR! path /usr/lib/node_modules
npm ERR! code EACCES
npm ERR! Error: EACCES, access '/usr/lib/node_modules'
npm ERR!     at module.exports (/usr/lib/node_modules/npm/lib/install/access-error.js:4:18)
npm ERR!     at /usr/lib/node_modules/npm/lib/install/writable.js:30:25
npm ERR!     at /usr/lib/node_modules/npm/node_modules/graceful-fs/graceful-fs.js:241:16
npm ERR!     at Object.oncomplete (fs.js:108:15)
npm ERR!  { [Error: EACCES, access '/usr/lib/node_modules'] code: 'EACCES', path: '/usr/lib/node_modules' }
npm ERR! 
npm ERR! Please try running this command again as root/Administrator.
npm ERR! Please include the following file with any support request:
npm ERR!     /home/famasboy88/.npm/_logs/2017-11-27T14_18_13_000Z-debug.log

2) Even if I was successful in installing Heroku, I think I will run into another problem (Well, mostly on accounts within FREE PLAN like me LOLL)

I tried to test if I could pass through and test a connection *$ wget "https://www.heroku.com"*

Sadly....

--2017-11-27 14:36:43--  https://cli-assets.heroku.com/
Resolving proxy.server (proxy.server)... 10.0.0.202
Connecting to proxy.server (proxy.server)|10.0.0.202|:3128... connected.
Proxy tunneling failed: ForbiddenUnable to establish SSL connection.

Which is telling me that Heroku is not included in the public whitelist of PA

Anyways, feel free to point out if I made any mistakes Peace!

Ah, you're right -- it does need sudo. I was wrongly assuming (because it's not on the command line) that it didn't, but looking at the script I can see that it does.

what I did: 1. Do not npm install -g 2. I installed nodejsv9.8.0 from nodejs.org(not in / but set alias in .bashrc)