pip install throwing "Permission Denied"

I have created a django app and i was trying to install the django-taggit module, but it throwing permission denied. i'm using a beginner account,is it because of that?

pip install --user fred

+1 to what jgmdavies says. You need the --user flag for pip (or easy_install) because otherwise it will try to install it system-wide, and you don't have permissions for that

thanks guys,it's worked


I've the same problem, so I tried pip install --user marco but I get an error that says: Could not find a version that satisfies the requirement marco (from versions: ) No matching distribution found for marco

what should I do? thank you in advance

EDIT: I found this : so used the command pip install --user pwhich ... and it worked btw when I try pip install django-taggit the error is: OSError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/django_taggit-0.21.3.dist-info'

please, do you know what I could do ?

EDIT 2: I'm sorry, I found the solution. I had to enter in the virtual environment. And there is no need to create the user :)

If you want to use the --user flag, you need it for all pip installs:

pip install --user django-taggit

I would probably recommend switching to a virtualenv though:

thank you so much


I used to have similar problem on installing kivy... I got it after using pip install --user kivy... Voilla!, thanks all.

Hey budies, we're not yet done... I had this kivy installed as such pip install --user kivy; loll, then I happened to type this on python 3.6 console :

from kivy import *

would you belief? here it came...

>>> import kivy

Traceback (most recent call last): File "<stdin>", line 1, in <module> ModuleNotFoundError: No module named 'kivy'

am I still having the mess?

You have not installed kivy into Python 3.6. Use pip3.6 to do that.

Thank You So Much It Works

thanks a lot. it worked