PythonAnywhere Forums

Django CKeditor Import Error

Hi,

I've tried to get ckeditor to install and tried to follow your debug instructions at https://help.pythonanywhere.com/pages/DebuggingImportError/

Still getting this error (below).

I've tried doing :

  • pip2.7 install --user django-ckeditor
  • pip3.6 install --user django-ckeditor
  • pip3.4 install --user django-ckeditor
  • Going into the virtual env, workon etc seeing it's python version 3.4 and doing pip install django-ckeditor from there.

    Error running WSGI application
    2017-10-08 03:26:19,145: ModuleNotFoundError: No module named 'ckeditor'
    2017-10-08 03:26:19,145:   File "/var/www/andycv_pythonanywhere_com_wsgi.py", line 88, in <module>
    2017-10-08 03:26:19,146:     application = get_wsgi_application()
    2017-10-08 03:26:19,146: 
    2017-10-08 03:26:19,146:   File "/usr/local/lib/python3.6/dist-packages/django/core/wsgi.py", lin e 13, in get_wsgi_application
    2017-10-08 03:26:19,146:     django.setup(set_prefix=False)
    2017-10-08 03:26:19,146: 
    2017-10-08 03:26:19,146:   File "/usr/local/lib/python3.6/dist-packages/django/__init__.py", line 27, in setup
    2017-10-08 03:26:19,147:     apps.populate(settings.INSTALLED_APPS)
    2017-10-08 03:26:19,147: 
    2017-10-08 03:26:19,147:   File "/usr/local/lib/python3.6/dist-packages/django/apps/registry.py", line 85, in populate
    2017-10-08 03:26:19,147:     app_config = AppConfig.create(entry)
    2017-10-08 03:26:19,147: 
    2017-10-08 03:26:19,148:   File "/usr/local/lib/python3.6/dist-packages/django/apps/config.py", line 94, in create
    2017-10-08 03:26:19,148:     module = import_module(entry)
    

Any ideas? I just don't think anything's actually installing. Been troubleshooting it over the last 2 days. Even tried to get tinymce working as an alternative.

Thanks, Andy

[edit by admin: formatting]

Can I take a look at your files? We can see them from our admin interface, but we always ask for permission first.

Yes, feel free.

The virtual environment is django18

This is my first django website. The idea is to make it a portfolio for my coding projects. Once I get it working I'm going to get a paid hacker account and just keep adding to it project by project :)

Hi there, it looks like your webapp is using Python3.6, so you need to run

pip3.6 install --user django-ckeditor

or switch to using a virtualenv...

Thanks I've got it working! I'll write up a guide on what I did and post it on these forums.