CNAME setup on 1&

Hi Guys,

Just trying to connect my webapp with my domain on 1& So far i've created the subdomain and set the CNAME as<p> I set this about 10pm last night GMT and it still hasn't updated, and is not working.<p> Do i need to set the CNAME as : ? <P> And is there any other configuration that needs to be changed? As i'm still getting a DNS error saying the CNAME hasn't been setup.

Any help appreciated, cheers.

When you say that you have set the cname, do you mean that you have gone to your domain registrar and set the www cname to It doesn't seem like you did that successfully for example when you check this.

Yes i've created the subdomain and then set the CNAME to what my app has output.

This is what i need help with as i need to check to see if i've not configured it correctly or that it's something with the registrar as i'm quite new to setting this up. Also i've tried searching for information but haven't come up with anything so far with regards to setting this up on 1&1

image of domain settings option on domain settings

It looks like it's all sorted now -- when I check your DNS settings I see the correct CNAME, when I visit your page it works, and it looks like there's no error on the "Web" tab.

Perhaps it was just taking a while for the DNS setup to fully sync? Or did you change anything after your last post?

Thanks Giles, Yes it's all working now but I did have to do some extra config to get the DNS to work. For anyone else having issues with 1&1 you also need to edit the "Destination" and set this to "http" redirect then type in the full web app address so mine looked like this:


Then i just refreshed the webapp a few times this morning and after a few hours had updated


Hi there, that "redirect' setting really doesn't look right. My guess is that the CNAME setting is what actually fixed it, but it took some time to propagate?

Hi Harry, Possibly however i set the CNAME on monday night and by wednesday evening it still hadn't updated and also i was still getting a DNS error on my app. Then last night i updated the destination and by this monring it was working and no DNS error on my app. But it's the first time i've ever set this up so i'm not too hot on it, though the 1&1 help and guides are pretty poor also so i don't really know, unless it was just to do with resetting the cname again but why it didn't work the first time is a bit of a mystery

Right, two days definitely should be long enough. Very odd. Still, if it's working now then I guess all is well.

my troubleshooting for 1and1: 1.) set http redirect service to the subdomain that you are going to create, i.e. 2.) create subdomain and select CNAME instead of IP and paste "" just as displayed in your webtab. On you can see that propagation does not take longer than a few minutes. On the show details view you will see that the "Target" is the CNAME as specified by your under manage subdomain. 3.) Once I figured that out, my app worked after not longer than 10 min, i.e. after I adjusted the allowed hosts in the django settings file.